Unknown filesystem, entering rescue mode

Hello everyone. I’m new to Manjaro and Linux in general, and after installing Manjaro alongside Windows 10 I’m now having a problem of unabling to boot correctly into either os, instead entering rescue mode every time. I can boot into Manjaro or Windows from the rescue, however, and the distro works fine at the moment.

What I did:
at first I installed Manjaro using probably outdated guide in my native language, but it didn’t booted at all, so then I reinstalled, using guide for dual boot installation from this forum (can’t include links yet)
After following guide I stumbled upon the described above problem, but I was able to boot into Manjaro at all, so I was happy.
I tried to solve my problem by recreating steps to solution from the thread called “New to manjaro: grub rescue unknown filesystem”.
The thing I have in common with the OP is that we both have Manjaro and Windows Boot Manager pointing out to


This is my result from

efibootmgr -v
BootCurrent: 0004
Timeout: 0 seconds
BootOrder: 0004,0001,0003,0002,2001,2002,2003
Boot0000* manjaro       HD(8,GPT,ab1443f5-c84f-1b42-aad2-33ee7c9563bc,0x2b2e2960,0x1006a0)/File(\EFI\manjaro\grubx64.efi)
Boot0001* Windows Boot Manager  HD(1,GPT,ebfb2a5f-0667-45c3-a751-f2167da023ba,0x800,0x2fd41)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* Linux HD(1,GPT,ebfb2a5f-0667-45c3-a751-f2167da023ba,0x800,0x2fd41)/File(\EFI\Linux\BOOTX64.efi)RC
Boot0003* Windows Boot Manager  HD(1,GPT,ebfb2a5f-0667-45c3-a751-f2167da023ba,0x800,0x2fd41)/File(\EFI\manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.}...t................
Boot0004* manjaro       PciRoot(0x0)/Pci(0x13,0x0)/Sata(1,0,0)/HD(1,GPT,ebfb2a5f-0667-45c3-a751-f2167da023ba,0x800,0x2fd41)/File(\EFI\Manjaro\grubx64.efi)A01 ..
Boot2001* EFI USB Device        RC
Boot2003* EFI Network   RC

ok, I guess I solved it. I deleted windows boot manager, after that everything broke down. Then, I restored grub and installed refind, this is probably not ideal, and now I can’t boot into windows, but I can boot into Manjaro, which is fine, because windows can go to hell.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.