Unknown devices in hardware detection tool, bluetooth not working as expected

I just received a brand new pc with Intel Raptor CPU. Nearly everything is working with Manjaro 22.0.4 with the kernel 6.1, except Bluetooth, because scanning won’t find any device and I wonder why. I’m also wondering why Manjaro is showing me a lot of unknown devices in the hardware overview, even when lspci -v will show me that for all devices, a driver was found and loaded. This is really some irritating. Why can the hardware list in Manjaro not be show correctly, since it seems that the devices are known devices.

The issue was also mentioned here #119866.

The problem with bluetooth is, that I can scan for devices with bluetoothctl but it will not find any of my devices

lscpi wikk show me this output

00:14.3 Network controller: Intel Corporation Device 7a70 (rev 11)
        Subsystem: Intel Corporation Device 0094
        Flags: bus master, fast devsel, latency 0, IRQ 18
        Memory at 6001114000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [c8] Power Management version 3
        Capabilities: [d0] MSI: Enable- Count=1/1 Maskable- 64bit+
        Capabilities: [40] Express Root Complex Integrated Endpoint, MSI 00
        Capabilities: [80] MSI-X: Enable+ Count=16 Masked-
        Capabilities: [100] Latency Tolerance Reporting
        Capabilities: [164] Vendor Specific Information: ID=0010 Rev=0 Len=014 <?>
        Kernel driver in use: iwlwifi
        Kernel modules: iwlwifi

There is no extra bluetooth module, but I think than Wlan controller also offers Bluetooth.

inxi will report this information about Bluetooth

  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-14:9
    chip-ID: 8087:0033 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 0 state: up address: <filter>
  Info: acl-mtu: 1021:4 sco-mtu: 96:6 link-policy: rswitch sniff
    link-mode: peripheral accept service-classes: rendering, capturing, object
    transfer, audio, telephony

Any ideas, what the issue could be? Thank you in advance.

Have you installed linux-firmware ? Yes of course

from Arch wiki

Bluetooth coexistence

If you have difficulty connecting a bluetooth headset and maintaining good downlink speed, try disabling bluetooth coexistence [15]:


options iwlwifi bt_coex_active=0

Note: Since kernel version 5.8, the bt_coex_active and sw_crypto module options have been disabled for the hardware handled by the iwlmvm kernel module. For older hardware handled by the iwldvm module, the options are still enabled.

@weingeist Thank for quick reply. linux-firmware was installed. I tried your hint with iwlwifi bt_coex_active and also restarted Bluetooth service, but it won’t help. But since Wifi is deactivated on my PC, it’s maybe another issue. But I’ll also try to update the firmware from the drivers page

Unfortunately, I couldn’t solve the issue. So I temporarily deactivated the WLAN with integrated Bluetooth in the Bios and use instead an external BT-USB-Dongle, which works out of the box. I hope, any of the next kernel releases will bring the solution.

1 Like