Unity3D - Have error when launch it : " Failed to initialize unity graphics

Hi everyone,

I have problems when i want launching my project game :

Fatal Error! Failed to initialize unity graphics. Please make sure that your graphics card drivers are installed/up to date and that it meets the minimum requirements listed in our website.

When I launched it the first time it worked.

My graphics card its : NVIDIA Ge Force 1060 3GB

Thanks in advance for your responses.

Hi there,
Please share some system info;

inxi -Farzy
mhwd -li -l

It may make sense to share the unity software as well. To search installed packages;

pacman -Qs unity

This guide has lots of extra hints like how to format code, etc.

1 Like

Thank you for your quick reply.

So here is what the command inxi -Frazy shows me :

  Kernel: 6.6.19-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc avail: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=41e744a3-86f6-4388-9ead-649a3cc97b17 rw quiet splash
  Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
    v: 5.115.0 wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: B150M-A D3 v: Rev X.0x
    serial: <superuser required> part-nu: SKU uuid: <superuser required>
    UEFI: American Megatrends v: 2201 date: 03/13/2017
  Info: model: Intel Core i3-7100 bits: 64 type: MT MCP arch: Kaby Lake
    gen: core 7 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 9 microcode: 0xF4
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 800 min/max: 800/3900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 bogomips: 31211
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling mitigation: Microcode
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
  Type: retbleed mitigation: IBRS
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: conditional,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GP106 [GeForce GTX 1060 3GB] vendor: Micro-Star MSI
    driver: nvidia v: 550.54.14 alternate: nouveau,nvidia_drm non-free: 545.xx+
    status: current (as of 2024-02; EOL~2026-12-xx) arch: Pascal code: GP10x
    process: TSMC 16nm built: 2016-2021 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1c02 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
    compositor: kwin_x11 driver: X: loaded: nvidia gpu: nvidia display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 54 s-size: 903x508mm (35.55x20.00")
    s-diag: 1036mm (40.79")
  Monitor-1: Unknown-1 mapped: HDMI-0 res: 1920x1080 hz: 60 dpi: 305
    size: 160x90mm (6.3x3.54") modes: 1024x768
  API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
    drv: swrast gbm: drv: kms_swrast surfaceless: drv: nvidia x11: drv: nvidia
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.54.14
    glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce GTX 1060 3GB/PCIe/SSE2
    memory: 2.93 GiB
  API: Vulkan v: 1.3.276 layers: 5 device: 0 type: discrete-gpu name: NVIDIA
    GeForce GTX 1060 3GB driver: nvidia v: 550.54.14 device-ID: 10de:1c02
    surfaces: xcb,xlib
  Device-1: Intel 100 Series/C230 Series Family HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3
    chip-ID: 8086:a170 class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10f1 class-ID: 0403
  API: ALSA v: k6.6.19-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 04:00.0 chip-ID: 10ec:8168
    class-ID: 0200
  IF: enp4s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Realtek RTL8188EUS 802.11n Wireless Network Adapter driver: N/A
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3
    chip-ID: 0bda:8179 class-ID: 0000 serial: <filter>
  Info: services: NetworkManager,systemd-timesyncd
  Local Storage: total: 698.65 GiB used: 98.77 GiB (14.1%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: HD501LJ size: 465.76 GiB
    block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s tech: N/A
    serial: <filter> fw-rev: 0-10 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Maxtor model: STM3250310AS
    size: 232.88 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    tech: N/A serial: <filter> fw-rev: A scheme: GPT
  ID-1: / raw-size: 232.59 GiB size: 227.88 GiB (97.98%)
    used: 98.77 GiB (43.3%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 296 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  Alert: No swap data was found.
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: nvidia temp: 26 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 49%
  Packages: 1498 pm: pacman pkgs: 1484 libs: 475 tools: pamac pm: flatpak
    pkgs: 14
  Active pacman repo servers in: /etc/pacman.d/mirrorlist
    1: https://manjaro.kurdy.org/stable/$repo/$arch
    2: https://manjaro.ynh.ovh/stable/$repo/$arch
    3: https://mirrors.cicku.me/manjaro/stable/$repo/$arch
    4: https://ftp.gwdg.de/pub/linux/manjaro/stable/$repo/$arch
    5: https://ridgewireless.mm.fcix.net/manjaro/stable/$repo/$arch
    6: https://forksystems.mm.fcix.net/manjaro/stable/$repo/$arch
    7: https://mirror.funami.tech/manjaro/stable/$repo/$arch
    8: http://manjaro.mirrors.theom.nz/manjaro/stable/$repo/$arch
  Memory: total: 8 GiB available: 7.68 GiB used: 4.3 GiB (56.0%)
  Processes: 220 Power: uptime: 1d 5h 56m states: freeze,mem,disk
    suspend: deep avail: s2idle wakeups: 3 hibernate: platform avail: shutdown,
    reboot, suspend, test_resume image: 3.06 GiB services: org_kde_powerdevil,
    power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
    tool: systemctl
  Compilers: clang: 16.0.6 gcc: 13.2.1 alt: 12 Shell: Zsh v: 5.9
    default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33

moderator note: fixed formatting

And command mhwd -li -l :

Installed PCI configs:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2023.03.23               false            PCI
       video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

0000:01:00.0 (0300:10de:1c02) Display controller nVidia Corporation:

              NAME               VERSION          FREEDRIVER           TYPE

      video-nvidia            2023.03.23               false            PCI
video-nvidia-470xx            2023.03.23               false            PCI
video-nvidia-390xx            2023.03.23               false            PCI
       video-linux            2018.05.04                true            PCI
 video-modesetting            2020.01.13                true            PCI
        video-vesa            2017.03.12                true            PCI

0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:

              NAME               VERSION          FREEDRIVER           TYPE

     network-r8168            2023.09.12                true            PCI


And finally this command pacman -Qs unity :

local/lib32-libappindicator-gtk2 12.10.0.r298-1 Allow applications to extend a menu via Ayatana indicators in Unity, KDE or Systray (32-bit) (GTK+ 2 library)


So it would appear you do not have any version of unityhub installed, which is the suggested tool for ‘managing unity editor installs’ according to the archwiki.

Unity3D - ArchWiki

As to the actual error … your gfx looks ok to me.

There are some various approaches to problems, such as clearing a malformed settings, further down the page at the same link;


1 Like

This seems strange to me because it worked fine the first time.
Finally I opted to uninstall & reinstall Unity3D.

However, I have a question: Could the problem come from installed software? For example I installed Counter-Strike 2 on Steam, other graphics software like GeoGebra, Peek or even Blender.

To avoid these problems in the future could I create virtual environments so as not to affect the dependencies of other similar software with python when creating a virtual environment by 'activating with source environmentname/bin/activate