Uninstalling pipewire, dependency hell

I wanted to try pipewire, and I guess what I read on installing it was wrong. I installed manjaro-pipewire and the suggested optional packages, including easyeffects. I tried running easyeffects, but it isn’t working, so of course pulseaudio is still running. I thought that manjaro-pipewire removed pulseaudio, but I guess not. So I thought that I’ll just uinstall pipewire and leave it be, but now when I try to uninstall anything that was installed with manjaro-pipewire and optional packages, pamac complains of other dependencies, including things that were installed before pipewire was installed, such as jack. What is the best way to go from here?

Solved: See the 4th post down by brahma

And just so that other people who might read this will know, I have briefly tested across a range of desktop applications and browsers, and all seems to be ok so far, including when selecting pulseaudio as an output in one application.

post output from:
pacman -Qs pulse

1 Like
$pacman -Qs pulse

local/lib32-libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
local/lib32-libpulse 16.1-1
    A featureful, general-purpose sound server (32-bit client libraries)
local/libcanberra 1:0.30+r2+gc0620e4-1
    A small and lightweight implementation of the XDG Sound Theme Specification
local/libpulse 16.1-1
    A featureful, general-purpose sound server (client library)
local/pavucontrol 1:5.0+r35+g964f298-1
    PulseAudio Volume Control
local/pipewire-alsa 1:0.3.56-1.0
    Low-latency audio/video router and processor - ALSA configuration
local/pipewire-pulse 1:0.3.56-1.0
    Low-latency audio/video router and processor - PulseAudio replacement
local/pulseaudio-alsa 1:
    ALSA Configuration for PulseAudio
local/pulseaudio-ctl 1.70-1
    Control pulseaudio volume from the shell or mapped to keyboard shortcuts.
local/xfce4-pulseaudio-plugin 0.4.3-1.1 (xfce4-goodies)
    Pulseaudio plugin for Xfce4 panel

remove also this:
sudo pacman -R pulseaudio-alsa
if it gives you dependency issues, post them here

1 Like

Removed. No issues.

so reboot and test the easyeffects

1 Like

Playing some test media, easyeffects seems to be working. Thanks!

Should I have done something different when installing manjaro-pipewire?

thats hard to tell, since we dont know what exactly you did when installing pipewire…

1 Like

From pamac I just installed manjaro-pipewire and the pamac suggested optional packages: easyeffects, pipewire-v4l2, pipewire-x11-bell, and I think helvum.

so you didnt do anything wrong, it just didnt remove the pulse-alsa package … and did you installed wireplumber?
pacman -Qs wireplumber

1 Like

I didn’t explicity install anything else outside of the pamac suggested optional packages for manjaro-pipewire. But wireplumber is installed. Maybe it was the last optional package instead of helvum. I forget.

ok so thats all

1 Like

Much appreciated the help brahma.

You know, you can check /var/log/pacman.log

1 Like

I didn’t know that. Thanks.

Does pamac keep a separate log? Not seeing it in /var/log.

There is a log available from the pamac gui hamburger menu. Looks like the other package was realtime-privileges

open add/remove software, click the 3 dots and view history

I just found that myself. Never realized it was in there.

It looks like pamac transactions (lines beginning with [ALPM] ) are included in the pacman log but not the other way around. And I guess ALPM is the library that both use, so some of those in the pacman log are from pacman transactions too.

I’m not complaining, but it would be good to see more detail in the pamac logs, such as optional packages selected for install at the time of the main package install, just to help make it more clear why those packages were installed.