Uninstalled two versions of steam, "steam", and "steam native runtime" but a third steam exists

When I used to launch XCOM on steam it is very quick and efficient. That is why I preferred to play it on Manjaro. Recently something happened and new versions of steam appeared in my menu. Now when I try to load the game it has to update microsoft direct x which it never used to do. Also I am pretty sure I have XCOM downloaded more than once. I thought I would uninstall steam then make sure I install the correct version. I uninstalled the two versions and the third does not show up in the uninstall application. I am not sure how to find and uninstall it. Then also the uninstall the games.

I know there is needed information in order to resolve this issue, but I combed through FAQs and other posts and I am not sure what I need to post to get started. Forgive me it has been a while.

So you have another ‘steam’ that is not a package?

pacman -Qs steam

If not a package … then … how did you install it?

If you dont know … then I guess we have to find it.
Is it in your PATH? (can you launch it from the terminal?)

which steam

Thank you for the response.

When I typed the first command, nothing. It just gave me another entry prompt.

When I typed the second command:

Now what do I do?

So you installed the SNAP.
Maybe through pamac? If so remove it from there.

So, i tried to remove it from snap. When i tried to remove it through snap, I used:

sudo snap remove steam

It started, then it got hung. It said my drive was full, which it’s not, and now I cannot load manjaro under any of my log ins. Any suggestions for what to do next?

Are we sure about that?
SNAPs do tend to take up a lot of space … and if you have a lot of them …

I suppose chrooting might make sense.

So I was able to delete some things that were not needed. I had multiple copies of games downloaded because of the multiple steams on my system. All is fixed. Now I need to determine which steam I should actually use. That is a matter for another thread. I will research and put my findings at the end of this thread in case it helps another user.

By the way the third steam version was a snap.

So not so sure then :wink:

Yeah … we established that.

I will mark the appropriate solution then.

Thank you for your help. I still do not have a working steam. but I feel like that is a different topic.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.