Uninstalled apps and deleted files showing up in kmenu and krunner

I installed lutris and wine and inside it installed uplay and farcry 3 game.
I uninstalled them properly but wine, uplay like apps and some farcry 3 files are still showing up in kmenu (application menu) and KRunner when I search.
Although when I tried to open them it said not found.
Is there any way to delete these dead /false links from search in Kmenu and KRunner?
Thank you.

Did you logout from the recent account?

Check inside ~/.local/share/applications/ and remove unused *.desktop files too.

2 Likes

I have rebooted and logged out several times

Did that and the apps are gone but still some files like Uplay(~/Games/far-cry-3/…My pictures), launcher_log.txt(~/gamesfar-cry-3/…logs){and a lot of log files like this inside the far-cry-3 folder which doesn’t exist anymore ) are still showing up in Kmenu and KRunner

Then you might have some of those in ~/.local/share/RecentDocuments/

checked it but not such docs or files exist there, only some recently opened files that I opened recently, but not those which I mentioned.

You can delete apps through Menu editor (right click on menu icon). I don’t know whether this will have effect on KRunner.

It may be also Baloo issue. See baloo status.

1 Like

baloo command not found

My wrong, correct is balooctl status :wink:

1 Like

So I checked the monitor and it was working fine. I disabled and re-enabled it, but nothing changed.
Now I’m trying to delete the index and force re-indexing and re& logging in.
Edit: It solved the problem

Reindexing is usually the solution

Remember old days on the library - with filers and drawers with cards telling where a certain book is stored?

The index on a computer is similar - if you throw away a lot of books without removing the cards - you would have a similar problem - the index says it’s there but it’s not.

how to prevent these problems in future?

I am not a familiar with Plasma.

But as with any other indexer it should be a matter of manually running the indexer to rebuild the index.

If you have removed a folder from your home you can try with

 balooctl clear foldername
1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.