Uninstall mysql

Hey guys,
I’ve been trying to uninstall mysql but I keep getting this error.
“error:target not found :mysl”
Any help please :pray:

It is spelled wrong

Please give the exact command you tried and the output you got.

Thank you but it was my fault. I wrote it wrong by mistake here.

I tried: pacman - Rns mysql
And I keep getting this:
Error: target not found:mysql

So it is already uninstalled

This is (still) wrong syntax.

Also, check if you mean mysql++

Would require

sudo pacman -Rsn mysql++

Hmm, if you got

Error: target not found:mysql

You must have tried

$ pacman -Rns mysql

That packge doesn’t seem to be installed on your system.

Well no it’s not :pensive:

Same error again

What makes you think, you have the mysql package installed?
The error message you got tells you it’s not …

Most likely you mean mariadb and not mysql.

Please post output of:
pacman -Qo mysqld

If for some reason @moson’s post doesn’t point you in the right direction (sounds like it should)…

How did you install it? If it wasn’t with Pamac (Add/Remove Software) or Pacman, then they don’t know about it.

I get this:
/usr/bin/mysqld is owned by mariadb 10.5.9-1

Because when I type mysql - - version
I get:
Mysql Ver 15.1 Distrib 10.5.9-MariaDB, for linux (x86_64) using readline 5.1

Well, now you know what package to uninstall then. :wink:

So there you have the mariadb package.

$ pacman -Qo $(which mysql)
/usr/bin/mysql is owned by mariadb-clients 10.5.10-1

And the mysql on your system probably is provided by mariadb-clients package as well.