Unicode characters not displayed


i just recognized that my Manjaro Gnome installation does not display Unicode characters like U+1F4A1 inside any application (Code OSS, Notable, etc.). I just see a block (better: transparent block with border). All locales I have installed (English, German) are UTF-8. Is there a fix available? Already tried to find something on the web but without success.

Regards, Thomas

Hi there!

Check out this How-To thread:

Hope that helps :slightly_smiling_face:


thanks for the hint, but it does not work for some reason. I have this configuration:

   System Locale: LANG=en_US.UTF-8
       VC Keymap: n/a
      X11 Layout: at
       X11 Model: pc86

In /etc/locale.gen I only have en_US.UTF-8 UTF-8 and de_AT.UTF-8 UTF-8 uncommented. So I still do not know, why those unicode “emojis” (or characters) won’t be displayed.

Regards, Thomas

Use a font that has full UNICODE support… Most programming fonts still support ASCII-8Bit only. (As you’re mentioning Code OSS, Notable, …)


1 Like

I just wonder because on my company notebook those chars work like a charm (but therefore zsh icons won’t do it).

Regards, Thomas

Which font, please???


For sure the Ubuntu default font, I guess it’s their own font.

And what would be the name of that font, please?



settings on my Ubuntu 18.04: in VSCode I use Hack, 'Roboto Mono', Consolas, 'Courier New', monospace . Configured (via Tweaks): Window Title Ubuntu, interface Ubuntu Regular, Document Sans Regular and monospace Roboto Mono Regular.

Regards, Thomas

The character mentioned in the OP is an emoji and is not provided by Roboto Mono, Consolas and others, you need some additional fonts. U+1F4A1 is a lit bulb, I could display its monochrome version since ttf-symbola is installed on my system, for the colored ones I guess you need an emoji font such as noto-fonts-emoji.

In my terminal it looks like this :

Copy those fonts over from Ubuntu to Manjaro and use them in the same environment. (Terminal, VSSCode, …)