Unexpectedly slow download speed on Steam on Manjaro


When I’m downloading anything from steam, it downloads with a fairly constant 21 Mbps.
Internet speed according to Speedtest and Fast should be at least 800Mbps usually above, and I have a Windows 11 installed on the same computer, where steam does not have such issues.
CPU is basically idling (according to KSysGuard), it’s a 5800x3d, it should be plenty.
IOtop reports no significant disk usage, basically 0%, when I cat a large file, it correctly goes up to 100%

I’ve tried the usually recommended workarounds, clearing some cache, limiting download speed, changing region, disabling IPv6, change DNS provider, use dnsmasq (it’s running on my homeassistant pi), disable http2, and probably some other things too, and I think even the kernel have been updated too since I have this problem.

So, everything else is fast enough, except steam and only on linux. Any idea?

What about the steam data?
Is it mounted from somewhere else? Like an NTFS share?

Local NVMe SSD, ext4, separate partition, but same disk as system is installed on.

I feel like that is a steam side thing.
Searching the interweb shows signs it might be a dns thing, but it seems inconstant so I think that is just a false positive if it works.

I would not be surprised if the speeds are limited by valve because you are using linux.

Some suggest switching to flatpak version of steam. I question that.
This user f.ex followed the advice to switch to dnsmasq but without success. Then it just suddenly started to work after a while. Pretty sure it had nothing to do with dnsmasq.

Tried flatpak, it’s just as slow.

Yeah, the flatpak was a longshot that I did not even believe in, I just mentioned it since it was tested in that thread.

You have a ton of logs in ~/.local/share/Steam/logs/ (if on the “normal” steam, not flatpak), connection_log.txt for example.

Maybe dig around the logs in that folder and see if you can figure out what is happening?

Hey, I found a possible fix:
open the terminal and go to “nano .steam/steam/steam_dev.cfg” and paste these two lines there:
@nClientDownloadEnableHTTP2PlatformLinux 0
@fDownloadRateImprovementToAddAnotherConnection 1.0
Confirm the changes and save, then restart steam.
It worked for me like charm.

Thanks for the contribution @idk

For some more information …

  • The first option effectively disables HTTP2.

  • The second makes steam connect to more servers (from ~3 to ~10)
    Which can improve things for some … or make them a lot worse.

For some other references;


And a note from an Arch user on the git bug thread

So for those testing this out … be aware that you may actually favor the first option only.


@nClientDownloadEnableHTTP2PlatformLinux 0

Another note.
For flatpak installs of steam the configuration file path is different;

Didn’t fix anything for me unfortunately. Tried both only first line and adding second line and it did no change at all. Still capped at 22MB/s like always, which is quite frustrating when I can get over 70MB/s from Origin store which is even running over Proton!

Really hope someone finds the actual problem.