Unable to use or reinstall Brother HL L2395dw Printer

Apologies, I somehow deleted my previous post.

To sum up, I’ve had a brother HL L2395dw printer for over a year, but yesterday it stopped working. (It don’t know exactly when it stopped working, I have not tried to print with it for some months)
Whenever I tried to print something I would see ‘waiting for printer to become available’ in the queue.

I tried several troubleshooting ideas from google results and the arch linux CUPS wiki but none of them worked. I then tried to remove the printer and reinstall it and that’s where I’m stuck.

Somebody replied to my previous post suggesting I use the CUPS web interface and install the printer that way but while I can access the CUPS web interface my printer does not show up as local printer, but it DOES show up as a network printer despite being connected by USB.

Attempting to add the network printer to my system gives a list of Brother models and the associated drivers, but the model I have, the HL-L2395DW is not on the list and selecting a different model doesn’t work.

The printer was working at one time so I managed to do this at one point but something has gone off since I bought and configured it.

Troubleshooting this is a little beyond me . . .google hits have suggestions about overriding usb drivers and other things I’m not comfortable doing if I don’t know what the problem actually is. . . how do I go about troubleshooting this?

Thanks in advance!

EDIT

I was able to get the printer installed by enabling its wifi and installing it as a network device but now when attempting to print it always says 'Unable to locate printer ‘BRWXXXXXX.local’.

I found some resources about installing nss-mdms but the error message is the same.

are you sure, that your printer is functioning (tested with another computer)?

Hi, thanks for the response.

Yes, the printer is working. I was just able to print to it from a windows laptop.

under manjaro I have not installed brother so far, but in the past on ubuntu I made good experiences with the brother installation-scripts.
The one for your printer would apparently be this:
brother-link

this is for .deb of course, so you can not use it directly.

But there are installation-instructions (for arch) in german to be found here, maybe that helps?
https://wiki.archlinux.de/title/Brother-Drucker

Thanks for that link.

I don’t think my issue is getting the drivers installed, I installed drivers from the AUR when I first bought the printer last year. ( the package is brother-hll2395dw)

To restate, I am now able to get the printer reinstalled using the CUPS web interface, but I cannot print anything from my manjaro system and it gives the error ‘Unable to locate printer’

I’ve tried various solutions I found on the net but my concern is that I don’t actually know what the root problem is, so I’m wary of just trying something I don’t really understand.

How do I go about finding the real problem?

well sorry, I won’t be able to help you.
Triggered by your post I started to try to get our brother MFC795CW printer to work,
on my machine not even cups is working so far :slight_smile:

just found this for you…
https://web.math.rochester.edu/people/faculty/akrish11//2016/01/09/cups-unable-to-automatically-locate-printer-2.html

Ha ha, thanks I did find that link as well and tried what it suggested.

nss-mdns was not installed so I installed it.

However my nsswitch.conf looks like this

hosts: files mymachines mdns4_minimal [NOTFOUND=return] resolve [!UNAVAIL=return] dns mdns4 myhostname

I . . . don’t actually know if mdns4 _minimal and mdns4 is significantly different from mdns_minimal and mdns . . .or if the extra entries in my file are a problem but that’s just another example of things I don’t really feel comfortable editing when I don’t really understand the issue.

Good luck with your system. . . .

EDIT:

I was never able to fix this problem, but it kind of went away. I still am unable to print to the printer over the network, it STILL gives ‘unable to find printer’ as an answer, but today . . . it just started working if I printed over USB.

Originally, USB was not working with the error code ‘waiting for printer to become available’ and I turned to network printing in desperation after it couldn’t find the printer over a usb connection. Oh well.