Unable to use my Bluetooth, Camera and Screen Sharing

Hello everyone,
I was using Bluetooth on my headset but due to some unknown issue my Bluetooth headset stopped and I tried reconnecting which didn’t helped. I also tried rebooting but the problem persisted. I tried to find a solution on forums but none of them could fix my issue. After some time I noticed that my webcam has also stopped working. I can confirm that my hardware is working good since my Bluetooth and camera work fine on windows (I have dual boot).

I tried bluetoothctl with sudo but it gave me the following output:

Agent registered
[bluetooth]# power on
No default controller available

Here is my system information

  Kernel: 5.13.19-2-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64
  root=UUID=c630f615-2d06-420a-8b53-89c3b0db4c23 rw quiet splash apparmor=1
  security=apparmor udev.log_priority=3
  Console: pty pts/0 wm: gnome-shell DM: GDM 40.1 Distro: Manjaro Linux
  base: Arch Linux
  Type: Laptop System: ASUSTeK product: VivoBook_ASUSLaptop X412DA_X412DA
  v: 1.0 serial: <filter>
  Mobo: ASUSTeK model: X412DA v: 1.0 serial: <filter>
  UEFI: American Megatrends v: X412DA.315 date: 03/25/2021
  ID-1: BAT0 charge: 6.7 Wh (20.2%) condition: 33.1/37.1 Wh (89.2%) volts: 7.8
  min: 7.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
  status: Charging cycles: 313
  RAM: total: 5.75 GiB used: 2.48 GiB (43.2%)
  Array-1: capacity: 32 GiB slots: 2 EC: None max-module-size: 16 GiB
  note: est.
  Device-1: DIMM 0 size: 4 GiB speed: 2400 MT/s type: DDR4
  detail: synchronous unbuffered (unregistered) bus-width: 64 bits
  total: 64 bits manufacturer: Hynix part-no: HMA851S6AFR6N-UH serial: N/A
  Device-2: DIMM 0 size: 4 GiB speed: spec: 2667 MT/s actual: 2400 MT/s
  type: DDR4 detail: synchronous unbuffered (unregistered) bus-width: 64 bits
  total: 64 bits manufacturer: Hynix part-no: HMA851S6JJR6N-VK
  serial: <filter>
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
  socket: FP5 bits: 64 type: MT MCP arch: Zen family: 17 (23)
  model-id: 18 (24) stepping: 1 microcode: 8108109 cache: L1: 384 KiB
  L2: 2 MiB L3: 4 MiB bogomips: 33553
  Speed: 1224 MHz min/max: 1400/2100 MHz base/boost: 2100/3700 boost: enabled
  volts: 1.2 V ext-clock: 100 MHz Core speeds (MHz): 1: 1224 2: 1223 3: 1368
  4: 1224 5: 1223 6: 1224 7: 1223 8: 1224
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel
  bus-ID: 03:00.0 chip-ID: 1002:15d8 class-ID: 0300
  Display: server: X.org 1.20.13 compositor: gnome-shell driver:
  loaded: amdgpu note: n/a (using device driver)
  resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.41.0
  5.13.19-2-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  v: kernel bus-ID: 03:00.1 chip-ID: 1002:15de class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor
  driver: snd_pci_acp3x v: kernel alternate: snd_rn_pci_acp3x bus-ID: 03:00.5
  chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel
  v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.13.19-2-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel
  bus-ID: 01:00.0 chip-ID: 8086:24fd class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 476.94 GiB used: 120.38 GiB (25.2%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW512G8
  size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
  lanes: 4 type: SSD serial: <filter> rev: 002C temp: 31.9 C scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 182.15 GiB size: 178.23 GiB (97.85%)
  used: 120.35 GiB (67.5%) fs: ext4 block-size: 4096 B dev: /dev/nvme0n1p5
  maj-min: 259:5 label: N/A uuid: c630f615-2d06-420a-8b53-89c3b0db4c23
  ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%)
  used: 29.9 MiB (11.7%) fs: vfat block-size: 512 B dev: /dev/nvme0n1p1
  maj-min: 259:1 label: SYSTEM uuid: 988E-6B37
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 16 MiB fs: N/A label: N/A
  uuid: N/A
  ID-2: /dev/nvme0n1p3 maj-min: 259:3 size: 200.89 GiB fs: ntfs label: OS
  uuid: 90DC903ADC901C92
  ID-3: /dev/nvme0n1p4 maj-min: 259:4 size: 92.12 GiB fs: ntfs
  label: New Volume uuid: 1A000F91000F72D5
  ID-4: /dev/nvme0n1p6 maj-min: 259:6 size: 800 MiB fs: ntfs label: RECOVERY
  uuid: E036DA2736D9FE8A
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-4:2 info: Elan Micro ELAN:Fingerprint type: <vendor specific>
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
  chip-ID: 04f3:0903 class-ID: 0000
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 62.2 C mobo: 62.0 C gpu: amdgpu temp: 62.0 C
  Fan Speeds (RPM): cpu: 3100
  Processes: 275 Uptime: 53m wakeups: 5 Init: systemd v: 249 tool: systemctl
  Compilers: gcc: 11.1.0 Packages: 1315 pacman: 1305 lib: 370 flatpak: 4
  snap: 6 Shell: Bash (su) v: 5.1.8 running-in: gnome-terminal inxi: 3.3.07

I have tried Downgrading my kernel version from 5.13.19-2 to 5.10.70-1 but it didn’t helped.

Also this is the output of rfkill

rfkill list all
0: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: asus-wlan: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: asus-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no

If you need any more information for solving my issue, please ask.

Thanks in advance

Hello, kernel 5.13 is EOL.

Could you try instead a newer kernel ? 5.14 is fine and stable.

If it still does not work, I’ve read another post with a Bluetooth issue fixed with 5.15 rc.
But as it’s not stable yet, I’d recommend to try first 5.14.

Hey thank you for replying

I tried kernel 5.14.
At start my device was plugged in and my bluetooth worked fine, I even tried connecting my pc to another bluetooth device and it successfully got connected.
To check if it solved my issue I unplugged my device and the bluetooth again went off.
I have noticed similar behavior when I degraded my kernel.
I tried restarting bluetooth and also re-plugging my laptop but that didn’t solved my issue.
The same with camera. Manjaro is unable to detect it but windows did it easily.
Also I noticed I am unable to share my screen both on google meet and discord.
Could this all problems be interlinked???

As you said I tried 5.15 kernel but that didn’t solved my problem either.

Please help me to solve all my issues to return to normal usage.

Same as another thread, I don’t get bluetooth on my machine, so I could not be very helpful on that matter :sweat:

Again, I’d call for help @Fabby, @Aragorn, @cscs, if you are, or know someone, good on Bluetooth troubleshooting.

1 Like