Unable to use external monitor (CPU AMD RYZEN 3500u, iGPU Vega 8) -- WHY OH WHY?


I’ve been using Manjaro for over 3 years without any issues on my old Intel laptop. My preferred DE is Cinnamon. Few days ago I’ve switched to a new laptop, this time AMD based (Ryzen 3500u and Vega 8 iGPU). The problem is that I can’t connect an external monitor to HDMI, it doesn’t work. The screen starts flickering regularly and that’s it. The external monitor doesn’t react at all. I’m at odds on what to do, read a lot of topics here but can’t seem to find a solution as most of them are related to hybrid laptops which mine is not.

BTW, the problem is not with a port as the external monitor works perfectly well while I’m booted to a live USB…

Appreciate your input. Thanks in advance!

  Kernel: 5.9.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.9-x86_64 
  root=UUID=236fb09c-12fc-4a06-a27f-9d85e23f6e86 rw quiet 
  radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 
  amdgpu.cik_support=1 modprobe.blacklist=radeon udev.log_priority=3 
  Desktop: Cinnamon 4.8.6 tk: GTK 3.24.26 dm: LightDM 1.30.0 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP 255 G7 Notebook PC 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 
  serial: <filter> 
  Mobo: HP model: 85EA v: 51.24 serial: <filter> UEFI: Insyde v: F.33 
  date: 08/17/2020 
  ID-1: BAT1 charge: 40.6 Wh condition: 41.3/40.9 Wh (101%) volts: 13.0/11.3 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Charging 
  Info: Quad Core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP arch: Zen/Zen+ note: check family: 17 (23) 
  model-id: 18 (24) stepping: 1 microcode: 8108102 L2 cache: 2 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 33550 
  Speed: 1224 MHz min/max: 1400/2100 MHz boost: enabled Core speeds (MHz): 
  1: 1224 2: 1224 3: 1259 4: 1364 5: 1224 6: 1226 7: 1224 8: 1226 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Picasso vendor: Hewlett-Packard driver: amdgpu v: kernel 
  bus ID: 04:00.0 chip ID: 1002:15d8 class ID: 0300 
  Device-2: Cheng Uei Precision Industry (Foxlink) HP Webcam type: USB 
  driver: uvcvideo bus ID: 3-2.1:3 chip ID: 05c8:0238 class ID: 0e02 
  serial: <filter> 
  Display: x11 server: X. Org 1.20.10 driver: loaded: amdgpu,ati 
  unloaded: modesetting alternate: fbdev,vesa display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
  s-diag: 583mm (23") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.39.0 
  5.9.16-1-MANJARO LLVM 11.1.0) 
  v: 4.6 Mesa 20.3.4 direct render: Yes 
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.1 chip ID: 1002:15de 
  class ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Hewlett-Packard driver: N/A 
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus ID: 04:00.5 
  chip ID: 1022:15e2 class ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel bus ID: 04:00.6 chip ID: 1022:15e3 
  class ID: 0403 
  Sound Server: ALSA v: k5.9.16-1-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 01:00.0 
  chip ID: 10ec:8168 class ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: rtl8821ce v: N/A 
  modules: rtw88_8821ce,8821ce port: 2000 bus ID: 02:00.0 chip ID: 10ec:c821 
  class ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  Device-1: Realtek Realtek Bluetooth 4.2 Adapter type: USB driver: btusb 
  v: 0.8 bus ID: 3-2.3:4 chip ID: 0bda:b00a class ID: e001 serial: <filter> 
  Message: Required tool hciconfig not installed. Check --recommends 
  Local Storage: total: 238.47 GiB used: 14.02 GiB (5.9%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix 
  model: BC511 HFM256GDJTNI-82A0A size: 238.47 GiB block size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 rotation: SSD 
  serial: <filter> rev: HPS0 temp: 39.9 C scheme: GPT 
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 14.02 GiB (6.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  ID-2: /boot/efi raw size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 312 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: file size: 512 MiB used: 0 KiB (0.0%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 55.0 C mobo: 20.0 C gpu: amdgpu temp: 55.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 263 Uptime: 14m wakeups: 1 Memory: 5.81 GiB 
  used: 2.03 GiB (35.0%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  Packages: pacman: 1184 lib: 356 flatpak: 0 Shell: Bash v: 5.1.0 
  running in: gnome-terminal inxi: 3.3.01

So I deleted modprobe.blacklist=radeon and radeon.si_support=0 radeon.cik_support=0 from grub (just trying different options), updated it and restarted the laptop. Then I connected the external monitor and it was working… Until another restart. It’s so confusing and irritating! Why can’t it simply work?

I shall mention that I’m also experiencing the error Failed to start Load/Save Screen Backlight Brightness of backlight:acpi_video0. However, it seems that after the restart not only the screen brightness is affected as I’m again unable to use the external monitor…

I think I found a solution. I’ve switched to kernel 5.4.100-1 and it’s working now without issues. :slight_smile:

EDIT: No… It worked for only a while and then the laptop’s screen started flickering while the external one just went blank. I don’t want switch to Windows (I hate it)… Have hope that someone might help as I’m feeling hopeless now.

Just tried one more time, the whole laptop just froze after inserting HDMI cable. Laptop’s screen went blank subsequently. This one’s new for me…