Unable to use 4k@120: LG C2 / 4090 / x11 & Wayland / 2.1 certified

I’m at a complete loss.

Problem statement: anytime I switch to 120hz I lose input; interestingly sometimes it works but on the next login/wake it loses input again.

Note: 4K@120hz RGB Full 12-bit HDR works in windows with zero issues (yes I’m aware there’s some downsampling magic happening)

What I’ve tried:

  • 3 different 2.1 certified cables (3-5ft)
  • 3 different ports on TV (GPU has 1 HDMI)
  • YCbCr422, 444, RGB Full
  • 6-bit, 8-bit dithering
  • No dithering
  • 10-bit no dithering via xorg.conf
  • TV on PC mode and HDMI mode
  • TV deep color on/off
  • EDID swap from working user (EDID decode matched)
  • nvidia_drm.modeset=0|1
  • nvidia_drm.fbdev=0|1
  • cvt & xrandr add
  • 119hz
  • Wayland and X11
  • Custom xorg.conf.d configs
  • PopOS, Fedora, and Manjaro (Manjaro works at least sometimes, lol)
  • update monitors.xml


  • nvidia-smi works fine
  • modeset updates fine
  • FRL is supported
  • TV bandwidth is fine @ 1198 MHz

I have only used nvidia 550.45 drivers. I know I’m missing stuff I’ve tried, but feel free to ask and I can share. Would love to figure this out, seems to be an issue when the TV converts from TMDS to FRL, thought it might be an EDID thing, but to no avail.