Unable to update Manjaro Gnome

Hi All,

I’m trying to update my system to latest version.
When I’m running following command:

sudo pacman -Syu

I received below error message:

:: Synchronizing package databases…
core is up to date
extra is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade…
:: Replace pamac-common with extra/libpamac? [Y/n] y
resolving dependencies…
looking for conflicting packages…
error: failed to prepare transaction (could not satisfy dependencies)
:: installing pacman (6.0.0-1) breaks dependency ‘pacman<5.3’ required by package-query

Can you please advise how can I solve this issue?

Thank you!

why use package-query is a dead package for us (used by yaourt) … remove it

when I’m trying to delete package-query I receive similar error, see bellow:

sudo pacman -R package-query
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing package-query breaks dependency ‘package-query>=1.9’ required by yaourt

OR

sudo pacman -Rs package-query
checking dependencies…
error: failed to prepare transaction (could not satisfy dependencies)
:: removing package-query breaks dependency ‘package-query>=1.9’ required by yaourt

@papajoke can you please advise what I can do in this case

“rm” yaourt :wink: is dead since … 2 years

thank you!
it works for me

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.