Unable to start dbus and startx

Hey all, I’ve now for vm purposes finally gottwn the IOMMU groups split for my two cards, but I can only get a display on either vm using the RTX 2070, or the integrated graphics, but none from the GTTX 1050Ti, I’ve tried every driver available, the good news is that lspci -nnk is no longer saying the 1050 is using the vfio-pci kernel driver but I’m still not getting a display. Here’s the startx error output

X.Org X Server 1.20.10
X Protocol Version 11, Revision 0
Build Operating System: Linux Manjaro Linux
Current Operating System: Linux jamesbuild1 5.10.6-arch1-1-vfio #1 SMP PREEMPT Wed, 13 Jan 2021 06:07:54 +0000 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux-vfio root=UUID=8664d69c-2452-4d25-918d-da21dec591ab rw intel_iommu=on iommu=pt vfio_iommu_type1.allow_unsafe_interrupts=1 pcie_acs_override=downstream,multifunction vfio-pci.ids=10de:1f07,10de:10f9
Build Date: 16 December 2020 10:33:32PM

Current version of pixman: 0.40.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.1.log”, Time: Wed Jan 13 19:45:14 2021
(==) Using config directory: “/etc/X11/xorg.conf.d”
(==) Using system config directory “/usr/share/X11/xorg.conf.d”
Failed to connect to bus: Operation not permitted
dbus-update-activation-environment: error: unable to connect to D-Bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
dbus[2723]: Unable to set up transient service directory: XDG_RUNTIME_DIR “/run/user/1000” is owned by uid 1000, not our uid 0
Couldn’t exec startkde: No such file or directory
xinit: connection to X server lost

waiting for X server to shut down (II) Server terminated successfully (0). Closing log file.


Is this error you get from the host or a vm installation?
When a GPU is dedicated to the vm it will no longer be available to the host.

Sorry if it wasn’t clear, this is an error on the host manjaro. I have 2 gpus + the integrated intel graphics. I’m fine with the 2070 being used on the vm but would like to have the 1050ti run things for manjaro the host. I’ve tried a bunch of drivers and it will continue not displaying anything unless I plug into integrated graphics.

Share the /etc/X11/mhwd.d/nvidia.conf to see what GPU is used there. Also, usually the GPU for host should be connected to the primary PCI port, but since you also want to use the iGPU will make things a bit more complicated for linux and would be like using hybrid graphics + configuration.
Eventually share the config for the VM and what you added to the IOMMU groups. The 1050 should not be present there. Someone might have a better idea after that.

So I checked for that file, it didn’t exisit, I only have video-linux and video-modesetting, so I installed video-nvidia to see what that would do with that file. I’ve had it installed before, but it didn’t get me a display so I’d uninstall it. I tried to copy and paste from vim but I couldn’t figure it out, I figured out how to yank but not how to paste to pastebin, here’s a screenshot.

So now it’s a file after installing it. I don’t need to use iGPU, my 1050 has 3 ports, and counting the tv and 2 monitors, I’m good that way. I have previously patched the kernels so that the VM would stop taking the 1050 and the 1050 and 2070 are now on their own groups.

Okay, so I restarted after installing video-nvidia, wasn’t getting any display, figured I’d just go into tty2 and uninstall, reboot. Now I’m getting a cursor but that’s it. I tried to uninstall and reinstall video-Linux from a live media, that didn’t help, I used a live media to restore from a time shift hours earlier today, no dice. Now I’ve got no display anywhere.

Heyo, I’m still really stuck, everytime I try something I get no display, I’ve since started trying to just pretend I don’t have integrated and stick with just using the 1050 but I get no display still. I’ve been trying other available drivers with different combos, I’ve tried posting to different forums and I’m getting nowhere with this.