Unable to set language to english

Hi!

New user here. I set locales to nb_NO when installing, but set english as language. After installing the language is a weird mix of english and norwegian all over the place. For instance in the pamac-manager most of the language is in norwegian. I’d like to switch everything over to english except date formats and such. Can anyone point me in the right direction?

I’ve set english as language under local settings -> detailed settings.

I’ve also set english as default language in plasma settings.

Control center -> Manjaro settings manager -> locale settings ->Detailed settings




If understand correct !

Actually the settings are set according to my expectation here. I want all formats to be in norwegian, but the system language itself to be in english.

I’ve set the top 4 ones to english. The rest is set to norwegian. Still a lot of norwegian words on buttons and folders here and there.

I hope you won’t mind me hijacking your post, but I have the exact same issue on my desktop (with English and French, after a fresh install).

Like on my laptop, I wanted to have Linux in English, while locale and keyboard would be set to French. So, I installed Manjaro in French and then changed its Display Language to English in the Manager, with its locale set to French. After a couple reboots, it partialy switched menus to English, but there are still menus and buttons in French.

It’s qute odd, as I don’t have any issue on my laptop.

Anybody has a suggestion on how to force Manjaro to use English when Manjaro Settings Manager→Locale Settings doesn’t work? :slight_smile:

No worries. Just glad you’re bringing attention to this thread.

And yes! That is exactly the same problem as me. My menus are just a mix of english and bad norwegian translations right now.

I also went into System settings > Regional settings > Language and here I only have one option (Plasma-translations), where I have set American English.

1 Like

I managed to solve this by manually editing the locale.conf file.

Not really sure how this works under the hood, but locale did not ouput the same as cat /etc/locale.conf. There seems to be multiple files for locale settings.

I manually changed LANGUAGE to en_US.UTF-8 with sudo nano /etc/locale.conf.

Had to reboot after

1 Like

Thx for the info & glad to know you solved it.
So, I just checked my /etc/locale.conf, and it looks alright to me—as far as the noob I’m can tell :wink:

LANG=en_US.UTF-8
LC_NUMERIC=fr_FR.UTF-8
LC_TIME=fr_FR.UTF-8
LC_MONETARY=fr_FR.UTF-8
LC_PAPER=fr_FR.UTF-8
LC_NAME=fr_FR.UTF-8
LC_ADDRESS=fr_FR.UTF-8
LC_TELEPHONE=fr_FR.UTF-8
LC_MEASUREMENT=fr_FR.UTF-8
LC_IDENTIFICATION=fr_FR.UTF-8

Sure, it’s not a huge deal. It’s just annoying to see menus and buttons here and there that do not use the correct locale :wink:

Okay! Try to add a line below LANG=en_US.UTF-8 that looks like

this LANGUAGE=en_US.UTF-8

This is what my locale.conf looks like.

LANG=en_US.UTF-8
LANGUAGE=en_US.UTF-8
LC_NUMERIC=nb_NO.UTF-8
LC_TIME=nb_NO.UTF-8
LC_MONETARY=nb_NO.UTF-8
LC_PAPER=nb_NO.UTF-8
LC_NAME=nb_NO.UTF-8
LC_ADDRESS=nb_NO.UTF-8
LC_TELEPHONE=nb_NO.UTF-8
LC_MEASUREMENT=nb_NO.UTF-8
LC_IDENTIFICATION=nb_NO.UTF-8
1 Like

I did as you suggested and it works, sort of: after a log out, it looks like menus and buttons are all in English, save the “Date/Time” extension in the Panel and its popup calendar (sorry, I can’t embed images for the moment, I guess my ‘rank’ has been reset with the change of forum)

That’s great to have menus in English, thx a lot!

Quick edit a reboot later: things are back to the starting point or close: now, everything is in French… and I can’t get it to use English at all. Time do some more research :wink:

1 Like

Oof. That sucks. After a few reboots everything is still fine here. Linux can be confusing at times. :confounded:

Yep, it can be. But that’s no problem. It just means some more stuff to learn… as soon as I can set aside some time to do research. And you already provided me a very useful lead here :wink:

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.