Unable to set grub default time

Hello fellow members,

I am unable to reduce the grub delay on booting my Manjaro KDE. I tried using sudo /etc/default/grub and set the timeout as 0 but it still counts down from 10 seconds. This was not the case before.
Fyi, I have openSUSE dual booted. However this did not cause any problem so far since installation.
I ran a “sudo update-grub” command today though, for the first time since installing openSUSE.

Im new to Linux and Manjaro and still learning hence your kind help would be highly appreciated.


No, don’t do that, and especially not on a dual-boot system. It also doesn’t make any difference in the timeout.

The thing is that Manjaro uses a customized GRUB, so you need to make sure that Manjaro’s GRUB is in control. The command…

sudo update-grub

… must be run from within Manjaro, and you must of course also make sure that the /etc/default/grub you modified is the one belonging to Manjaro, and not to openSUSE.

If it still doesn’t work after running the command, then you can try (from within Manjaro)… :arrow_down:

sudo grub-install --recheck --no-rs-codes && sudo update-grub

Did that… doesnt work. Very strange.

I tried this from Manjaro. Also tried your sudo-install option. Doesnt work my friend… any other option?

Can you give some more details? For example:

  • Are you using Manjaro’s or openSUSE grub?
  • What OS installed grub on your ESP respectively MBR?
  • When exactly in the boot process you have this delay?
  • Can you share your etc/default/grub for review?
1 Like

Hi Wollie
-im using Manjaros grub.
-Manjaro OS
-the delay im speaking about is the grub menu countdown, which is currently 10seconds. I tried changing it to 0 to avoid OS selection. But no matter what I do, the countdown begins from 10s.
for your reference:

GRUB_CMDLINE_LINUX_DEFAULT="quiet apparmor=1 security=apparmor udev.log_priority=3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment this option to enable os-prober execution in the grub-mkconfig command

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

Change this to


and run

sudo update-grub

Then reboot.

1 Like

This is the error on doing so:

[rp@rp-hp14ce ~]$ sudo update-grub
Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
Its output will be used to detect bootable binaries on them and create new boot entries.
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount': Device or resource busy
rmdir: failed to remove '/var/lib/os-prober/mount': No such file or directory

@Wollie retrying once again…

@Wollie thank you very much. It worked. May i ask how to do away with the menu. I mean i dont want the menu to appear at all and directly take me to Manjaro. Is this possible?

1 Like

Makes not much sense to me in a dual boot situation, especially if it cost you only 3 seconds to see the menu. If you don’t do anything it boots the last booted system, due to


You could try 2 seconds, though :laughing:.

In the menu if I select openSUSE, it doesnt load… there r errors. Hence I have to press F10 (bios setting) while starting the laptop and then set openSUSE as priority 1. Only then im able to choose openSUSE to work. However when Manjaro is set as priority 1 in BIOS (F10) only Manjaro works. Thats why I was thinking to do away with the grub menu at all.

I think this is a new issue, better open a new thread for this. It could be also an openSUSE issue, so not sure if this can be fixed here, but feel free to try.

1 Like

Thank you very very much for the help @Wollie

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.