Unable to see USB stick listed in boot device list

Currently using a Acer Nitro 5 (AN515-52-53DH), here the details:
Intel (R) Core ™ i5-8300H CPU @ 2.30GHz 2.30 GHz Processor
Installed RAM 8.00 GB (7.85 GB usable)
System type 64-bit operating system, x64-based processor
Pen and touch input Touch or handwritten input is not available for this screen

I am trying to boot Manjaro from a USB, the problem is that every time I start the computer and enter the list of boot devices, only my hard drives are shown (2).
I have tried using Rufus, balena etcher and Universal USB Installer in case it was the way I burned the ISO’s, I have also tried changing the BIOS settings to disable secure boot, and I have followed a number of tutorials whose titles I go to attach, however, I have not achieved my purpose.
It should be clarified that I have reviewed this with two USB sticks of different brands and on a different computer where the problem does not appear.
In advance, many thanks to anyone who can help me.

- manjaro-kde-20.2.1-210103-linux59

Videos I’ve tried:

[How to install linux on Acer nitro5]

[Acer Nitro 5 AN515-54 boot from a USB Flash Drive BIOS EDIT]

[:computer: How to Disable UEFI Secure Boot - Acer Nitro 5]

[NO BOOTABLE DEVICE Error Fix Latest 2019||Acer Nitro 5 Series 100% Fix||First On Youtube||]

Only two issues are a) is your iso written validly (there are issues with some programs and some distros…maybe try a different program to write it) Personally I write with DD from Linux.
The other is a BIOS issue, and not having the same model I can’t say what you might need to check or change to include removeable drives.

Like I said, I tried using Rufus, Universal USB Installer, and balenaEtcher, but nothing.
On the other, I was looking a little more and it seems that the problem is related to my system’s incompatibility with Legacy, it only works with UEFI, but I honestly do not understand what that means.

Some thoughts that might help:
Some bios’s have the option to fast boot to the installed drive, the boot skips the initialization of the other boot methods, is there an option to disable fastboot?
Sometimes a password is needed to be able to disable secure boot, it is set and enabled?
Do you have to actively add the usb option to the options in the bios to get it to show up as a valid boot device?

I didi it by testing programs until I found “the one”.
Yes, I already had the passwords set and the secure boot disabled, I didn’t see the fastboot thing, but hey, I already found my solution: YUMI-UEFI- plus the settings in the BIOS.
Also, thank you for your comments.

I got it, tried different programs, balenaEtcher, LinuxLive USB Creator, rufus, Universal-USB-Installer and UNetbootin, until I tried with YUMI-UEFI and it worked.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.