Unable to satisfy dependency 'libsysprof-capture' required by glib2

I’m new to manjaro

$ pamac checkupdates          
30 available updates:
bash                     5.1.012-1          -> 5.1.016-2           core
btrfs-progs              5.15.1-3           -> 5.16-1              core
ca-certificates-mozilla  3.73.1-1           -> 3.74-1              core
cryptsetup               2.4.2-3            -> 2.4.3-1             core
curl                     7.80.0-1           -> 7.81.0-1            core
ding-libs                0.6.1-3            -> 0.6.1-4             core
e2fsprogs                1.46.4-1           -> 1.46.5-1            core
efivar                   37-4               -> 38-1                core
expat                    2.4.2-1            -> 2.4.3-1             core
glib2                    2.70.2-1           -> 2.70.2-2            core
grub                     2.06-2             -> 2.06-4              core
hdparm                   9.62-1             -> 9.63-2              core
iana-etc                 20211203-1         -> 20220110-1          core
iproute2                 5.15.0-2           -> 5.16.0-1            core
libpipeline              1.5.4-1            -> 1.5.5-1             core
linux-firmware           20211027.1d00989-1 -> 20211216.f682ecb-1  core
linux510                 5.10.89-1          -> 5.10.93-1           core
logrotate                3.18.1-1           -> 3.19.0-1            core
manjaro-release          21.2.1-1           -> 21.2.2-1            core
mdadm                    4.1-2              -> 4.2-1               core
nss                      3.73.1-1           -> 3.74-1              core
pacman                   6.0.1-2            -> 6.0.1-3             core
pciutils                 3.7.0-1            -> 3.7.0-2             core
sqlite                   3.37.0-1           -> 3.37.2-1            core
systemd                  250-5              -> 250.2-1             core
systemd-libs             250-5              -> 250.2-1             core
systemd-sysvcompat       250-5              -> 250.2-1             core
usbutils                 014-1              -> 014-2               core
util-linux               2.37.2-4           -> 2.37.2-5            core
util-linux-libs          2.37.2-4           -> 2.37.2-5            core
$ pamac update         
Preparing...
Synchronizing package databases...
Refreshing core.db...                                                           
Resolving dependencies...                                                       
Warning: cannot resolve "libsysprof-capture", a dependency of "glib2"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'libsysprof-capture' required by glib2

how could I update those? thanks.

What is the output of:

sudo pacman -S libsysprof-capture
$ sudo pacman -S libsysprof-capture

error: target not found: libsysprof-capture

Oh I admit that I use a pacman mirrow

$ sudo pacman-mirrors --status

Local mirror status for stable branch
Mirror #1   --  55:34   China  https://mirrors.tuna.tsinghua.edu.cn/manjaro/
Mirror #2   OK  07:33   China  https://mirrors.ustc.edu.cn/manjaro/
Mirror #3   OK  00:53   China  https://mirrors.sjtug.sjtu.edu.cn/manjaro/
Mirror #4   --  49:33   China  https://mirror.nju.edu.cn/manjaro/
Mirror #5   --  55:34   China  https://mirrors.tuna.tsinghua.edu.cn/manjaro/

Does this affect?

Refresh mirror list and try again:

 sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu

wow now I have 284 packages to be updated. working

Check out


https://archlinux.org/packages/extra/x86_64/libsysprof-capture/files/

Upstream

https://wiki.gnome.org/Apps/Sysprof

Also


https://forum.manjaro.org/t/how-can-i-install-sysprof-capture/99276/2

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.