Unable to run tqsl (trustedqsl) after latest update

Trying to run tqsl ver 2.6.5-2 (Logbook of the World app) now fails with error:

“libtiff.so.5: cannot open shared object file: No such file or directory.”

I tried removing and reinstalling and still same error. Seems as if the library mentioned above was removed during the latest update.


with a first short search through the Manjaro repositories as well as through the AUR
I could not find that program, at all.

This, perhaps?

AUR (en) - trustedqsl

but rebuilding did not help?


perhaps you can provide more background information

Yes the long name is trustedqsl. Building on Raspberry Pi-400. All was fine before the update. Executing the executable, tqsl, in a terminal window gives the error mentioned in my post. I had a similar issue with another update a while back and removing and rebuilding fixed it. Not this time. I have use it for years in various versions. By rebuilding I mean installing it using the Manjaro Install/Remove programs application.

What more information would you need? It is a standalone program so shouldn’t depend on other programs. On another operating system for the RPi I build it myself from source and it goes fine. I realize that Manjaro works better if apps are installed/built by Manjaro itself so have refrained from doing that.

I’m sorry!
It’s not the first time that I overlooked the “ARM” tag of a post.

I can’t speak to ARM issues at all - zero experience.

No problem. I appreciate the effort.

Seems to me that a solution would be just find the library and install it, but maybe it’s not so simple.

Just a thought, or two…

libtiff.so.5 seems to have been replaced on Manjaro Plasma by libtiff.so.6. Perhaps the same for you? I only have the following now:


If it should explicitly ask for version 5 ought to mean it’s hard coded in the source somewhere. Header file or two? Not sure why one would do that, clearly other programs that might use that libtiff thing still work, but we’re not here to argue about design decisions.

You could try to replace any calls in the program’s source where version 5 is called upon, for version 6, recompile and see it it works. In Python I do this all the time, but I also duplicate the line, comment one out and update the other, unless I wrote it myself. It might work, but it depends, I guess, on how much the library has changed from 5 to 6. Other things might break instead.

I don’t use that program you talk about (that I know of) but I do know that some programs (perhaps not on Manjaro) has settings so you can turn features you don’t use off, like a certain file type such as the TIF format. Perhaps the library still needs to be present, but could be worth checking any docs or man pages if you don’t use it.

Or maybe try downgrading from 6 to 5? But that might affect other things now relying on version 6, so… plague or cholera, I guess… (as the saying goes where I live)

Or you could wait for any remaining maintainers to discover the problem. Or try alerting them, if you know where they live. :wink:

Disclaimer: I am not a C programmer, nor do I use ARM, which ought to be self-evident! I just get lots of ideas when I read about things like you described. :slight_smile:

Good luck! :slight_smile: