Unable to run `Memory Test` from Grub's boot menu: `error: file /boot/Memory not found`

If I select Memory Test in GRUB’s boot menu I get the error: file /boot/Memory not found message on the blank black screen.

Images having the issue (at least):

I let the image to find the file on installed OS copy: I installed Manjaro OS and retried again with bootable media: I see the same error. It looks like the file should be inside of ISO image.

I used ventoy 1.0.64 to boot images.

If you are using UEFI, then install memtest86-efi, not memtest86+. ​


You download the memtest ISO from the official website, then flash it into a USB stick.

The PC runs BIOS, not EFI

Yes, your suggestions could fix the issue: already ran the test under the installed OS copy environment using it’s boot menu.

The point was to report the issue: memtest can’t be executed under a LiveCD ISO environment. I think it is the issue: Boot menu item is present but does not work.

if it is matters, I burned ventoy with GPT and started that bootable media on BIOS-only machine.

On the installed system:

test -d /sys/firmware/efi && echo "efi" || echo "bios"
inxi -Mazy1
  Type: Laptop
  System: ASUSTeK
    product: K50IJ
      v: 1.0
      serial: <superuser required>
  Mobo: ASUSTeK
    model: K50IJ
      v: 1.0
      serial: <superuser required>
  BIOS: American Megatrends
    v: 218
    date: 04/09/2010

I think it is the known issue:

1 Like

I burned ventoy boot media with MBR.
Tried latest dev image mentioned in the initial post of the thread: the same error message.

I went through linked post Memory Test no longer included on live ISOs? - #2 by M0nst3r by Zesko and replaced the line to linux16 /boot/memtest.
Pressing Ctrl+X or F10 in try to save and boot it leads to PC reboot.

I went into GRUB cmd line:

It looks like it is the memtest file issue: it quits immediately after calling it, but if to install OS from the LiveCD media and do not update the OS, and to try to run Memory test in GRUB menu w/o any edition, then Memtest starts fine.