Unable to remove Virtualbox

Hello, not entirely new to Linux, but re-learning it. Completely new to Manjaro. I have some experience running Virtualbox in Windows - no problems. I used Pamac to install Virtual box here in Manjaro. It installed and would open, but would only allow for 32 bit iso support. I tried to open a session, but it failed to create the virtual drive. Thinking maybe I installed an incorrect version of Virtualbox, I tried to remove it via Pamac. repeatedly get an error that Pamac is unable to remove, due to broken dependencies. Sometimes Pamac completely freezes and I have to use Task Manager to kill the process.

[lyleb@lyle-hpstreamlaptop14cb1xxx ~]$ inxi --admin --verbosity=7 --filter --width
  Kernel: 5.15.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=11c151a7-1a03-4c1f-9ffc-12eaa1ad0517 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel wm: xfwm
    v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: HP product: HP Stream Laptop 14-cb1xxx v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: HP model: 84FB v: 97.20 serial: <superuser required> UEFI: Insyde
    v: F.19 date: 07/21/2021
  ID-1: BAT0 charge: 12.3 Wh (30.1%) condition: 40.9/40.9 Wh (100.0%)
    volts: 11.0 min: 11.3 model: HP Primary type: Li-ion serial: N/A
    status: discharging
  RAM: total: 7.58 GiB used: 1.67 GiB (22.0%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
  Info: model: Intel Celeron N4020 bits: 64 type: MCP arch: Goldmont Plus
    family: 6 model-id: 0x7A (122) stepping: 8 microcode: 0x1C
  Topology: cpus: 1x cores: 2 smt: <unsupported> cache: L1: 112 KiB
    desc: d-2x24 KiB; i-2x32 KiB L2: 4 MiB desc: 1x4 MiB
  Speed (MHz): avg: 1058 high: 1150 min/max: 800/2800 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1150 2: 967
    bogomips: 4378
  Flags: 3dnowprefetch acpi aes aperfmperf apic arat arch_capabilities
    arch_perfmon art bts cat_l2 cdp_l2 clflush clflushopt cmov constant_tsc
    cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts erms est fpu
    fsgsbase fxsr ht ibpb ibrs ibrs_enhanced ida intel_pt lahf_lm lm mca mce
    md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe
    pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pts rdpid rdrand
    rdseed rdt_a rdtscp rep_good sdbg sep sha_ni smap smep ss ssbd sse sse2
    sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tsc tsc_adjust tsc_deadline_timer
    tsc_known_freq umip vme x2apic xgetbv1 xsave xsavec xsaveopt xsaves
    xtopology xtpr
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 status: Vulnerable: eIBRS with unprivileged eBPF
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel GeminiLake [UHD Graphics 600] vendor: Hewlett-Packard
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2
    bus-ID: 00:02.0 chip-ID: 8086:3185 class-ID: 0300
  Device-2: Quanta HP Webcam type: USB driver: uvcvideo bus-ID: 1-6:4
    chip-ID: 0408:5222 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting alternate: fbdev,vesa gpu: i915 display-ID: :0.0
    screens: 1
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
    s-diag: 414mm (16.31")
  Monitor-1: eDP-1 model: ChiMei InnoLux 0x14c4 built: 2015 res: 1366x768
    hz: 60 dpi: 112 gamma: 1.2 size: 309x173mm (12.17x6.81") diag: 354mm (13.9")
    ratio: 16:9 modes: 1366x768
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Celeron/Pentium Silver Processor High Definition Audio
    vendor: Hewlett-Packard driver: snd_hda_intel v: kernel
    alternate: snd_soc_skl,snd_sof_pci_intel_apl bus-ID: 00:0e.0
    chip-ID: 8086:3198 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.38-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Hewlett-Packard driver: rtw_8822ce v: N/A modules: rtw88_8822ce
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 1000 bus-ID: 01:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 1-5:3 chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 524.05 GiB used: 40.89 GiB (7.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 vendor: Smart Storage Systems
    model: TX2964 size: 58.29 GiB block-size: physical: 512 B logical: 512 B
    type: SSD serial: <filter> rev: 0x8 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Seagate
    model: ST500LT012-1DG142 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B type: HDD rpm: 5400 serial: <filter> scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 57.99 GiB size: 56.78 GiB (97.91%) used: 17.25 GiB (30.4%)
    fs: ext4 dev: /dev/mmcblk0p2 maj-min: 179:2 label: N/A
    uuid: 11c151a7-1a03-4c1f-9ffc-12eaa1ad0517
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 288 KiB (0.1%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
    label: NO_LABEL uuid: 1413-EBCB
  ID-3: /run/timeshift/backup raw-size: 232.88 GiB size: 228.17 GiB (97.98%)
    used: 23.64 GiB (10.4%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18 label: Manjaro
    uuid: 27e937f4-b1c2-43af-8e31-2ed506f1b793
  Alert: No swap data was found.
  ID-1: /dev/sdb1 maj-min: 8:17 size: 232.88 GiB fs: ext4 label: MX Linux
    uuid: be01135a-c303-4803-804a-0df524061101
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 9 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:2 info: HP HP Wireless Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 12 Mb/s
    power: 100mA chip-ID: 03f0:2141 class-ID: 0301
  Device-2: 1-5:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:b00c class-ID: e001 serial: <filter>
  Device-3: 1-6:4 info: Quanta HP Webcam type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 0408:5222
    class-ID: 0e02 serial: <filter>
  Hub-2: 2-0:1 info: Super-speed hub ports: 7 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-1:3 info: ASMedia Ugreen Storage Device type: Mass Storage
    driver: uas interfaces: 1 rev: 3.1 speed: 5 Gb/s chip-ID: 174c:225c
    class-ID: 0806 serial: <filter>
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 184 Uptime: 4h 30m wakeups: 1 Init: systemd v: 250
  tool: systemctl Compilers: gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1219
  lib: 358 flatpak: 0 Shell: Bash v: 5.1.16 running-in: xfce4-terminal
  inxi: 3.3.15
[lyleb@lyle-hpstreamlaptop14cb1xxx ~]$ 

Two questions: Are there different installs based on 32 vs 64 bit, and I missed the distinction?

More importantly, any suggestions for overriding Pamac and uninstalling Virtualbox? I really cannot afford the wasted disk space this unusable install is taking up. Thanks.

Hi @lab
Support for 32 bit iso is defined when creating a new virtual machine. E.g.: Type: Linux, Version: Other Linux (32-bit)

For existing VMs that you used before in other systems make sure that you used the same VM version particularly when you used extension pack.

In Pamac you can set in Preferences > Advanced > Remove unrequired dependencies
Other than that you remove virtualbox with it’s dependencies in terminal by:

sudo pacman -Rs virtualbox

Sounds like you also have the extension pack virtualbox-ext-oracle from AUR installed. Remove that one first if it is installed. Another core dependency will be the kernel host module for virtualbox e.g. linux515-virtualbox-host-module and that will be removed together with virtualbox package.

Ok, thank you. I will give this a try.

Regarding setting up the virtual machine. I choose the Linux for “Type”, but the drop down for “version” includes only 32 bit options, no 64 bit options are offered.

All right. I did as you said, the file I needed to remove first was sudo pacman -Rs virtualbox-ext-vnc

After I removed this, I could successfully removed Virtualbox.

Again, thank you.

1 Like

@lab Glad that it worked!
I haven’t seen that VB is only offering 32 bit options. It’s new to me and don’t know why that is.
In an article from the Web I read that in Bios you need to enable Virtualization Technology. You maybe try this and see in VB if you get 64 bit support.

Thanks, I’ll give that a try. It isn’t really all that important that I get the Virtualbox running - I would just be playing with it. It is a bit of a “challenge” now though. :wink:

@lab Let us know when you found out why it’s like that!
Virtual Machines make technology life so much easier and more interesting :wink: .

You were absolutely correct. I had to enable Virtualization in the Bios. I then re-installed Virtualbox and I now have 64 bit options.

Thank you very much for your ongoing and timely responses. You have been a great help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.