Unable to remove var files of Waydroid

After the March '24 update, Waydroid completely stopped opening for me and would never even boot once, it was working absolutely fine before. So i tried to clean install waydroid and guides suggested i remove the var files.
I ran the command: sudo rm -rf /var/lib/waydroid /home/.waydroid ~/waydroid ~/.share/waydroid ~/.local/share/waydroid

I got the following:
rm: cannot remove '/var/lib/waydroid/rootfs': Device or resource busy

 sudo lsof +D /var/lib/waydroid/rootfs

gives me:

lsof: WARNING: can't stat() fuse.gvfsd-fuse file system /run/user/1000/gvfs
      Output information may be incomplete.

And nothing more. Would also be helpful if someone can help me identify the problem because of which waydroid stopped working in the first place

You had to uninstall the way you installed (pamac gui has buttons build and remove). You can see the buildscript of the aur package. It is probably installing some service that mounts the virtual filesystem. So you have to stop that and unmount first.

That suggests to me that it might be a mountpoint rather than just a directory. If you run:
mountpoint /var/lib/waydroid/rootfs
it should tell you. If it is, then you need to unmount it.

1 Like

This does say that its a mountpoint. But trying to unmount gives me:

umount: /var/lib/waydroid/rootfs: target is busy.

I’ve removed the waydroid package using yay AUR helper, but that doesnt seem to change that

Try rebooting. That’ll probably clear it.

Cleared it, thanks. But waydroid on reinstall still seems to crash