Unable to permanently turn off Bluetooth

Hi, I fell for the memes and am using a Thinkpad x200, however one thing that I have a problem with is that Bluetooth LED icon right next to Wifi is turning on after I’ve turned it off.

I am turning it off with:
$bluetooth off
And the output says:

bluetooth = off (software)

I’ve also tried to turn it off using GUI on my Manjaro XFCE, but that did not make any difference whatsoever.

I’ve also tried to stop the Bluetooth service in systemd, with:
$sudo systemctl stop bluetooth.service

And then disable it with:
$sudo systemctl disable bluetooth.service

And even check if it is inded turned off with:
$systemctl status bluetooth.service

However, none of this helps in the long run. It does help immediately, but within a few 10s of minutes or sometimes even seconds the Bluetooth LED turns on and when I check the state it says that it is, indeed, turned ON. It’s not just a phony LED indication.

Is there anything I can do to permanently turn off Bluetooth? Or at least for as long as I want, until I explicitly turn it on?

Trying masking the service.
A disabled service can be started by another service. If you really want it dead, without uninstalling it, then you can mask it to prevent it from starting under any circumstances:

You could set your bluetooth device default powerstate in /etc/bluetooth/main.conf

InitiallyPowered = True

Or blacklist

echo "blacklist bluetooth" | sudo tee /etc/modprobe.d/blacklist-bluetooth.conf

Or add a command to your startup process

rfkill block bluetooth

Perhaps mask the service

sudo systemctl mask bluetooth.service
1 Like

The very first method worked already. Although I’m more than happy to receive such a detailed response. I’m eager to learn about the system so I’m happy to receive such an answer.

I’ve added InitiallyPowered = True in /etc/bluetooth/main.conf
Saved it, closed it and I’ve checked if the reboot will break it, but no - It works like a charm.


Wow that link is amazing. Masking method works as well. Thanks! I will definitely learn about the systemd more.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.