Unable to open pamac-manager gui

Unable to open pacman gui, after clicking it appears in bar but then disappears and does not open, however terminal commands are working fine.

There is no such thing.
Perhaps you mean pamac ?

What happens if you attempt to open it from the terminal?

pamac-manager

There was recently a bug with pamac-flatpak-plugin
So if you see errors related to flatpak - that is the reason, and you can temporarily ‘fix’ it by removing the plugin package for now.

2 Likes

Thanks you understanding, Yes I ran the command, I got following output but gui opened and it was working fine.
(process:14052): GLib-GIO-WARNING **: 18:52:27.303: /etc/xdg/kde-mimeapps.list contains a [Added Associations] group, but it is not permitted here. Only the non-desktop-specific mimeapps.list file may add or remove associations.

But then I pinned it to my panel and then when I clicked on pinned icon I got a error.

You might try moving/renaming ~/.config/mimeapps.list

I faced the same issue and package manger was opening only after removing flatpak plugin.
sudo pacman -R pamac-flatpak-plugin

So, I resolved the issue by removing plugin, and ran the below command to reinstall flatpak and plugin.
sudo pacman -S flatpak
sudo pacman -S pamac-flatpak-plugin

You can try this workaround as it resolved the issue for me and is working perfect now.

I had the same issue and tried what you’ve said. It didn’t work for me.
Able to work after removing the flatpak-plugin.
Not working with re-install I mean

I can confirm that running.
sudo pacman -R pamac-flatpak-plugin
works