Unable to open external hard drive

The hard drive is encrypted and once I enter the correct password and mount it I get the following error when trying to open it:

Failed to open directory “seagate”.
Error opening directory ‘/run/media/manjaro/seagate:’ Permission denied.

How do I fix this?

Take ownership so that you have permissions?!

I tried that, but I wasn’t quite able to figure it out.

Do I do that before decrypting the drive or after?

sudo chown $USER:$USER /run/media/manjaro/seagate

The terminal just spits out a bunch of stuff that says read only when I run that after decrypting. If before decrypting what exactly would be the path?

Your drive’s hardware is failing my friend. The read-only mode is there to protect it from further damage.

That’s strange, it’s not that old and I’ve barely used it. I feel like given my lack of knowledge I’m probably making an error somewhere, rather than it being a broken hard drive.

Would help if you posted that terminal output too. If you think there is unique info in it just cut it out…

I’m not exactly sure what I did differently, but this time it worked and I was able to access the drive.