Unable to Mount USB Sticks - "An error occurred while accessing 'DEVICE', the system responded: The requested operation has failed: Error creating directory `/run/media/{username}`: Permission denied

I’ve been loading up USB sticks with data and, while working on this, have been trying new autofs configurations to try and get the sticks to automount in a different way and I think I’ve borked it.

I’ve not got anywhere with autofs for USB, so I’ve taken the elements I added there out completely (It was working fine for my nfs shares).

I’ve obviously kicked something somewhere as I now can’t seem to mount a stick the usual way anymore. Attempting to mount just gives the error above.

Why would this be and how can I get it back?

I’d go for a reboot but that’s out of the question at the moment as I’ve got a 3 day operation running on a secondary OS disk.

When I put a stick in this is my device tree via lsblk --fs

NAME        FSTYPE FSVER LABEL           UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
└─sda1      ext4   1.0   Cloud Linux     9d44b0e8-08c3-44d3-a2de-ab7df0f4492e  979.5G    68% /cloud
├─sdc1      vfat   FAT32                 3D66-94F4                                           
├─sdc2      ext4   1.0   Manjaro Gnome   5fe8aabe-45b7-490a-a64a-bf255650c1d0                
└─sdc4      ntfs         Scratch         082A54672A545432                        103G    69% /scratch
└─sde1      vfat   FAT32 ORBITAL         6EBA-01C5                                           
├─nvme0n1p1 vfat   FAT32 NO_LABEL        048C-6C0A                             298.8M     0% /boot/efi
└─nvme0n1p4 btrfs        Manjaro KDE     656d8930-a03a-4850-a10b-696abf952cd4  250.8G    46% /var/cache
├─nvme1n1p1 vfat   FAT32                 C459-1F93                                           
├─nvme1n1p3 ntfs         Windows         28FE59B8FE597ECE                                    
├─nvme1n1p4 ntfs                         603A302D3A300298                                    
└─nvme1n1p5 ext4   1.0   Timeshift Gnome 619ad6a1-afea-4b4b-9936-6076bed02705  

The stick is in /dev/sde1 so it’s there, just not mounted properly. Previously it was using /dev/sdd1 - not sure if that’s normal. It feels like I’ve locked something up with what WAS /dev/sdd1 but at this point my knowledge evaporates and I don’t know what to do to get it back.

I’ve tried putting a different USB stick in using the port next to the one I was using before and I get the same result as above (but with a different label).

Here’s my lsusb output for completeness…

Bus 002 Device 024: ID 30de:6545 KIOXIA TransMemory
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0b05:19af ASUSTek Computer, Inc. AURA LED Controller
Bus 001 Device 009: ID 058f:6254 Alcor Micro Corp. USB Hub
Bus 001 Device 008: ID 062a:4101 MosArt Semiconductor Corp. Wireless Keyboard/Mouse
Bus 001 Device 007: ID 413c:301c Dell Computer Corp. Dell Universal Receiver
Bus 001 Device 018: ID 043e:9a39 LG Electronics USA, Inc. USB Controls
Bus 001 Device 017: ID 045e:0772 Microsoft Corp. LifeCam Studio
Bus 001 Device 016: ID 0bda:5411 Realtek Semiconductor Corp. RTS5411 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

This article seems similar to my problem, but isn’t quite the same: https://askubuntu.com/questions/806762/permission-problem-on-media-user-folder-prevents-me-from-accessing-external-med

It did prompt me to look at the affected folder though.

If I ls-al at /run/media I get this.

total 0
drwxr-xr-x  2 root root   0 Jan 31 21:33 .
drwxr-xr-x 35 root root 900 Jan 31 21:48 ..

If I do sudo mkdir username I just get…

mkdir: cannot create directory ‘media/username’: Permission denied

This seemed really weird to me so I looked at the same folders on my Gnome Laptop and they look exactly the same and perform the same way, but the mounting just works - The username subfolder is created automatically and removed again when there’s no devices, so this seems to be a red herring.

I remain at a loss.

I managed to get this working again but only by rebooting, as my locking operation completed.