Unable to mount a USB thumb drive that us formatted NTFS

I am unable to mount this thumb drive in Manjaro even thou I don’t have a problem with it on same hardware with Windows 10, Linux Mint & Ubuntu. I am able to mount other USB thumb drives that are formatted with other FSs like exFAT or ext4. I get this error message.

Hi and welcome,

Screenshots are unecessary and copied text is more practical.

A helpful guide is here:

But I would probably bet dolphins to doughnuts that your ‘issue’ is that of the new ntfs3 module not allowing to mount partitions marked with a ‘dirty bit’, unlike the previous module ntfs-3g which would force-mount them anyways.

The ‘dirty bit’ is most usually the result of not properly dismounting the drive in windoze and/or windoze anti-feature 'Fast Startup" which actually ensures your system does not shut down but hibernates instead.

There are many similar threads here on the forum, including these:


Your approach should be as follows:

  • Use windoze or a clone like Hirens to run chkdsk on the drive/partition
  • In the future properly dismount drives and/or disable ‘Fast Startup’ for windoze.

  • You may optionally disable ntfs3 in favor of ntfs-3g, but know that you will be ignoring safety mechanisms and possibly causing continual damage to your data or drive.

It is not allowing me to post the screen shot that I had thought that was included. It says:
Error mounting /dev/sdf at /run/media/mrappe/6DCA58E85F8A6A96: wrong fs type, bad option, bad superblock on /dev/sdf, missing codepage or helper program, or other error.
Interesting that it mounts/dismounts ok on ubuntu and mint and not Manjaro.

As do many of the examples in the link above.

And my guess as to the ‘problem’ is still the same.

Not really, as they are probably using the old ntfs-3g module like mentioned above.

1 Like

Well, you could just link to your Reddit post. :wink:

I’ll drop this here in case it’s useful:

Windows chkdsk can also be run from bootable media:

Note: An OEM Windows Recovery Disc of any kind is not suitable.

Hi @mr_underhill

Your apparent disbelief should be easily dispelled by reading the following article. I hope it helps you to gain a better appreciation of what @cscs has already explained.


1 Like
  1. I ran a chkdsk on it but that found nothing and it was always “removed safely”
  2. I was able to mount it ok in Arch which has the ntfs-3g.
  3. In Manjaro I used sudo ntfsfix --clear-dirty /dev/sdg and that fixed it.

Thank You to all who replied.

Arch uses ntfs3 as well. Depending on kernel.

ntfsfix should usually be avoided. It really does not fix anything. It can only be used to remove the dirty bit (or the list of bad sectors). There is the off chance that its all you needed to do - like a faulty sensor. But it is often used with the mistaken belief that it has capabilities similar to chkdsk or fsck, leading to further damage.

My Arch install has ntfs-3g because I can call it directly but no ntfs3.

As I said.
Arch uses ntfs3 depending on kernel.


To do otherwise … you would need to explicitly blacklist the ntfs3 module.
(and install ntfs-3g package)

If you mean you reached your conclusion by not having an executable command called ntfs3 … that is not conclusive.

The ntfs3 module does not provide a ‘userspace utility’. Its just a module.

(this is like saying you do not use intel driver because you do not have a command called intel)

But if you are using a fairly old kernel. Older than 5.15. Then you wouldnt have ntfs3.
(unless you installed ntfs3-dkms from the AUR or similar)

I see that the ntfs3 is a kernel module so that it cannot be called directly like the ntfs-3g.
My Arch install has Linux 6.8.9-arch1-2 x86_64 installed I can call ntfs-3g so I must have installed it at some time but I don’t recall blacklisting anything.

$ ntfs-3g
ntfs-3g: No device is specified.

ntfs-3g 2022.10.3 external FUSE 29 - Third Generation NTFS Driver

  •   Configuration type 7, XATTRS are on, POSIX ACLS are on*

Copyright (C) 2005-2007 Yura Pakhuchiy
Copyright (C) 2006-2009 Szabolcs Szakacsits
Copyright (C) 2007-2022 Jean-Pierre Andre
Copyright (C) 2009-2020 Erik Larsson

Usage: ntfs-3g [-o option[,…]] <device|image_file> <mount_point>

Options: ro (read-only mount), windows_names, uid=, gid=,

  •      umask=, fmask=, dmask=, streams_interface=.*
  •      Please see the details in the manual (type: man ntfs-3g).*

Example: ntfs-3g /dev/sda1 /mnt/windows

Plugin path: /usr/lib/ntfs-3g

News, support and information: GitHub - tuxera/ntfs-3g: NTFS-3G Safe Read/Write NTFS Driver

NTFS-3G can coexist with NTFS3 to the extent that both drivers can be used. However, unless the kernel module has been blacklisted, NTFS3 will take precedence.

Regardless of this, it would then still be possible to use NTFS-3G when mounting a volume manually, for example.

As noted, this applies only when using kernels 5.15 and above, as NTFS3 was not present in previous kernels.

How would one blacklist ntfs3 since I don’t know how it would have happened in my Arch OS?

Check that it isn’t already blacklisted:

ls /etc/modprobe.d/

If you don’t see any likely files, or the directory is empty, it’s safe to assume NTFS3 has not been blacklisted.

Blacklist NTFS3:

echo 'blacklist ntfs3' | sudo tee /etc/modprobe.d/blacklist-ntfs3.conf

Note: To reverse this decision at any time, delete the blacklist-ntfs3.conf file:

sudo rm /etc/modprobe.d/blacklist-ntfs3.conf
  • NTFS3 will again take precedence when no longer blacklisted.
  • NTFS-3G can optionally remain installed for manual mounting.

Also note that the name of the file isn’t as important as remembering what it’s there for - you could name it bye-ntfs3.conf or anything you like.

The content of the file - “blacklist ntfs3” - is important, however.

The modproble.d directory came back empty. When I insert but it does not auto-mount and I don’t see it in lsblk. I was able to also mount it manually before I ran
ntfsfix --clear-dirty /dev/sdg
and I just used the regular mount commands and the device showed up in lsblk and sudo fdisk -l.

Just to explain what that command actually does;
in simple terms, for passers-by:

  • …oh, I have a mounting error - it looks like my NTFS volume might be damaged, and I should run chkdsk to try and fix it…
  • …ok, I ran chkdsk, but it wasn’t enough to fix it - maybe I should use a more thorough chkdsk scan - nah, that takes too long…
  • …ok, I’ll run ntfsfix so the error message doesn’t keep bugging me - I don’t care if the volume is damaged - I just want to keep doing stuff…

What’s wrong with this picture?

If chkdsk completes and has fixed all errors, it will automatically clear the dirty bit.

If NTFS3 still generates a mounting error, it’s because the dirty bit still exists (chkdisk needs to perform a deeper repair) or, there might be an as yet undiscovered configuration error (possibly in /etc/fstab).

OK. I guess I could just ‘reformat’ it since it only has a few spreadsheets on it which I can copy but it has been a learning experience to ask why.

Reformatting the volume might help; if it doesn’t, it could indicate a full chkdsk (including bad sector) scan/repair might still be needed (that could take a very long time on a USB drive).

However, if you’re going to format, consider using a native Linux filesystem (ext4 for example) or exfat, if you still need to access it from Windows.

exfat is not as resilient as ntfs (it has no recovery options, for example) - however, many consider it to give the least amount of problems (exfat was orininally designed to bridge the gap between Windows and macOS).

That said, don’t rely on exfat for long-term storage.

In Windows you’d likely have to pay for that learning experience. :wink:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.