Unable to make Rosegarden sounding

Hi all

I’m fighting with midi soud the final goal is to use Rosegarden making soud

inxi -A
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio driver: snd_hda_intel
           Device-2: NVIDIA GK208 HDMI/DP Audio driver: snd_hda_intel
           Sound Server-1: ALSA v: k5.14.14-1-MANJARO running: yes
           Sound Server-2: JACK v: 1.9.19 running: yes
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.39 running: yes

At this point where i am:

  • timidity -iADq -Os is running in the background to open my midi ports

  • I have two sondbanks FuildR3_GM.sf2 and FuildR3_GS.sf2 installed on /usr/share/soundfonts/

  • The lone app able to read midi files is Audacious with just Alsa or PulseAudio, strangely no midi ports needed ?

  • GuitarPro7 no midi sound

  • Drumstick looks like reading but any sound, i’ve checked all disponibles ports avaible one by one but nothing

  • Rosegarden the final goal comportement is exactly the same as Drumstick, looks like correctly reading but any sound

  • I tried some connections with QjackCtl but nothing worked, maybe i failed here i don’t know, i even don’t know if jack is usefull ?

  • no any media reader launched just to be sure nothing is squatting the sound card

I need help i don’t know what else to check and to do ?

PS: of course i’ve checked douzen of times nothing is muted anywhere


Looks like this

Audacious will support playback of .mid files using ALSA MIDI

But Rosegarden requires JACK for audio and MIDI to be bridged from ALSA to JACK using a2jmidid
The command to invoke a2jmidi can be added to QjackCtl to run after JACK is started:


Rosegarden and Jackmidi - LinuxMusicians

Support for aj2midid in QjackCtl | rncbc.org

1 Like