Unable to login to Manjaro just get booted back to login screen

I have just installed Manjaro XFCE on my desktop with the non-free drivers for my NVIDIA graphics card. I have not been able to log into the desktop as every time I attempt to login I get sent back to the login window.

I have attached the system info in the hidden section. I have attempted the steps as shown in other Manjaro forums.

I am able to access tty and ssh so I can access and use the terminal however still can’t seem to load into the desktop.

System Info
inxi -Fazy --no-host
  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=1f1a51b1-4d44-466b-8c4a-29339a6c3fdd rw quiet apparmor=1 
  security=apparmor resume=UUID=d2a31c1e-3308-4bb1-8e34-912dad457424 
  Console: tty 0 DM: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: CROSSHAIR VI HERO v: Rev 1.xx 
  serial: <filter> UEFI: American Megatrends v: 7901 date: 07/31/2020 
  ID-1: hidpp_battery_0 charge: N/A condition: N/A volts: 4.1/N/A 
  model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A 
  serial: <filter> status: Unknown 
  Device-1: sony_controller_battery_90:89:5f:a7:8c:55 model: N/A serial: N/A 
  charge: N/A status: Charging 
  Topology: 8-Core model: AMD Ryzen 7 1800X bits: 64 type: MT MCP arch: Zen 
  family: 17 (23) model-id: 1 stepping: 1 microcode: 8001138 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 115019 
  Speed: 3696 MHz min/max: 2200/3600 MHz boost: enabled Core speeds (MHz): 
  1: 3691 2: 2121 3: 2112 4: 2104 5: 2186 6: 2194 7: 2192 8: 2190 9: 2121 
  10: 2110 11: 2194 12: 2206 13: 2200 14: 2196 15: 3693 16: 2105 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GP102 [GeForce GTX 1080 Ti] driver: nvidia v: 450.66 
  alternate: nouveau,nvidia_drm bus ID: 0b:00.0 chip ID: 10de:1b06 
  Display: server: X.org 1.20.8 driver: nvidia tty: 190x49 
  Message: Advanced graphics data unavailable in console. Try -G --display 
  Device-1: NVIDIA GP102 HDMI Audio driver: snd_hda_intel v: kernel 
  bus ID: 0b:00.1 chip ID: 10de:10ef 
  Device-2: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel 
  v: kernel bus ID: 0d:00.3 chip ID: 1022:1457 
  Device-3: Logitech HD Pro Webcam C920 type: USB 
  driver: snd-usb-audio,uvcvideo bus ID: 1-13.1:6 chip ID: 046d:082d 
  serial: <filter> 
  Device-4: Sony DualShock 4 [CUH-ZCT2x] type: USB 
  driver: snd-usb-audio,sony,usbhid bus ID: 1-5:2 chip ID: 054c:09cc 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Intel I211 Gigabit Network vendor: ASUSTeK driver: igb v: 5.6.0-k 
  port: e000 bus ID: 05:00.0 chip ID: 8086:1539 
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Broadcom and subsidiaries BCM4352 802.11ac Wireless Network Adapter vendor: ASUSTeK driver: wl v: kernel modules: bcma port: e000 
  bus ID: 0a:00.0 chip ID: 14e4:43b1 
  IF: wlp10s0 state: dormant mac: <filter> 
  Local Storage: total: 2.52 TiB used: 64.63 GiB (2.5%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 vendor: Samsung model: SSD 960 EVO 500GB size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 
  serial: <filter> rev: 3B7QCXE7 scheme: GPT 
  ID-2: /dev/sda vendor: Seagate model: ST2000DM001-1CH164 size: 1.82 TiB 
  block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  rotation: 7200 rpm serial: <filter> rev: CC24 scheme: GPT 
  ID-3: /dev/sdb vendor: SanDisk model: SDSSDA240G size: 223.57 GiB 
  block size: physical: 512 B logical: 512 B speed: 6.0 Gb/s serial: <filter> 
  rev: 00RL scheme: GPT 
  ID-4: /dev/sdc type: USB vendor: Toshiba model: TOSHIBA USB DRV 
  size: 28.93 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: PMAP scheme: MBR 
  ID-1: / raw size: 401.47 GiB size: 394.16 GiB (98.18%) used: 7.39 GiB (1.9%) 
  fs: ext4 dev: /dev/nvme0n1p2 
  ID-2: /home raw size: 1.82 TiB size: 1.79 TiB (98.38%) 
  used: 57.24 GiB (3.1%) fs: ext4 dev: /dev/sda1 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 64.00 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p1 
  System Temperatures: cpu: 20.5 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 277 Uptime: 51m Memory: 31.35 GiB used: 531.6 MiB (1.7%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1076 lib: 333 
  flatpak: 0 Shell: Bash v: 5.0.18 running in: tty 0 (SSH) inxi: 3.1.05 
mhwd -li
mhwd -li
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-450xx            2019.10.25               false            PCI
   network-broadcom-wl            2018.10.07                true            PCI

Warning: No installed USB configs!
LightDM Status
systemctl status lightdm
● lightdm.service - Light Display Manager
     Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
     Active: active (running) since Sat 2020-09-12 09:14:01 AEST; 1h 8min ago
       Docs: man:lightdm(1)
   Main PID: 781 (lightdm)
      Tasks: 5 (limit: 38425)
     Memory: 55.2M
     CGroup: /system.slice/lightdm.service
             ├─ 781 /usr/bin/lightdm
             ├─1483 /usr/lib/Xorg :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
             └─1501 lightdm --session-child 12 19

Sep 12 09:14:00 arctic systemd[1]: Starting Light Display Manager...
Sep 12 09:14:01 arctic systemd[1]: Started Light Display Manager.
Sep 12 09:14:03 arctic lightdm[1260]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=969) by (uid=0)
Sep 12 09:14:13 arctic lightdm[1305]: gkr-pam: unable to locate daemon control file
Sep 12 09:14:13 arctic lightdm[1305]: gkr-pam: stashed password to try later in open session
Sep 12 09:14:13 arctic lightdm[1305]: pam_systemd_home(lightdm:account): systemd-homed is not available: Unit dbus-org.freedesktop.home1.service not found.
Sep 12 09:14:13 arctic lightdm[1305]: pam_unix(lightdm:session): session opened for user arctic(uid=1000) by (uid=0)
Sep 12 09:14:13 arctic lightdm[1305]: gkr-pam: gnome-keyring-daemon started properly and unlocked keyring
Sep 12 09:14:14 arctic lightdm[1305]: pam_unix(lightdm:session): session closed for user arctic
Sep 12 09:14:16 arctic lightdm[1490]: pam_unix(lightdm-greeter:session): session opened for user lightdm(uid=969) by (uid=0)

XFCE display configuration doesn’t play well with the nvidia driver somehow. Maybe that helps?

Thank you for this. Unfortunately this didn’t make any difference on my desktop.

1 Like

Did you upgrade your whole system?

sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syu

Partial upgrade = Broken System

Is there any relevant entry/error in the logs? sudo journalctl -b (after you have tried to log in)

I had the same issue with a recent install with KDE. I think there could be some problem accessing the specific nvidia driver from the mirrors. I have a GT210/218 card that worked fine with nonfree drivers in kubuntu.

If I install Manjaro (KDE) with free drivers, I can access the DE no worries and everything works, but I get laggy video playback in firefox. When I tried to change to the nonfree drivers using mhwd I get an error message to say that the file cannot be found on the mirror (sorry don’t have the output with me rn), so i updated my mirror list but it made no difference, i tried a few different methods. I was also unable to cahgne drivers using the GUI tool. both tools show the nvidia 340xx drivers as the one to go for, but DL fails.

I am not a linux wizard by any means, so you should verify everything I’ve said on your system, but by my experience it doesn’t look like it is to do with XFCE. Try installing with free drivers and go from there.

So I found out that NVIDIA stopped updating the drivers for my card a few kernels ago. I tried booting into an older kernel and installing the drivers for that, but I ended up back on the black login screen with mouse cursor.