Unable to login on resume due to the "empty" login screen

After today’s packages update I’m unable to login on resume (from suspend) due to the “empty” login screen: there’s only moveable cursor on the background (wallpaper) and nothing else (no controls and text inputs).
I’m switching display to an external monitor and using “hybrid mode” through Optimus Manager QT.
And that worked fine (excepting that the mouse is freezing from time to time) till the today’s update.
This is quite a trouble as it breaks a normal work forcing me to reboot on each resume.


EDIT:
When I change to another wallpaper in Workspace behaviourScreen Locking, I may see media controls on the screen but they are completely inactive (non-clickable/non-enterable).
Also, each resume event now shows a “frozen” inactive screen with an old time (captured on suspend)

$ inxi --verbosity=7 --filter --no-host 
System:
  Kernel: 6.6.5-3-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11
    wm: kwin_x11 vt: 2 dm: SDDM Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: G3 3779 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 04R93M v: A00 serial: <superuser required> UEFI: Dell
    v: 1.2.1 date: 07/18/2018
Battery:
  ID-1: BAT0 charge: 5.6 Wh (100.0%) condition: 5.6/56.0 Wh (10.0%)
    volts: 16.9 min: 15.2 model: Samsung SDI DELL W7NKD87 type: Li-ion
    serial: <filter> status: full
Memory:
  System RAM: total: 16 GiB available: 15.48 GiB used: 5.64 GiB (36.4%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
    required.
CPU:
  Info: 6-core model: Intel Core i7-8750H bits: 64 type: MT MCP smt: enabled
    arch: Coffee Lake rev: A cache: L1: 384 KiB L2: 1.5 MiB L3: 9 MiB
  Speed (MHz): avg: 1023 high: 3459 min/max: 800/4100 cores: 1: 800 2: 800
    3: 800 4: 800 5: 800 6: 800 7: 823 8: 800 9: 800 10: 800 11: 800 12: 3459
    bogomips: 52815
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid lahf_lm lm mca mce md_clear mmx monitor movbe mpx msr
    mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge
    pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp rep_good sdbg sep
    smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp syscall tm tm2
    tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi vpid x2apic
    xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
Graphics:
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel arch: Gen-9.5 ports: active: none off: eDP-1
    empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:3e9b
    class-ID: 0300
  Device-2: NVIDIA GP106M [GeForce GTX 1060 Mobile] vendor: Dell
    driver: nvidia v: 545.29.06 arch: Pascal pcie: speed: 2.5 GT/s lanes: 8
    ports: active: none off: HDMI-A-3 empty: none bus-ID: 01:00.0
    chip-ID: 10de:1c20 class-ID: 0302
  Device-3: Realtek Integrated Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 bus-ID: 1-5:3 chip-ID: 0bda:568a class-ID: 0e02
    serial: <filter>
  Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia dri: iris
    gpu: i915,nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: HDMI-A-3 mapped: HDMI-1-0 note: disabled pos: primary
    model: Philips PHL 274E5 serial: <filter> res: 1920x1080 hz: 60 dpi: 82
    size: 598x336mm (23.54x13.23") diag: 686mm (27") modes: max: 1920x1080
    min: 640x480
  Monitor-2: eDP-1 note: disabled model: LG Display 0x046e res: 1920x1080
    dpi: 128 size: 382x215mm (15.04x8.46") diag: 438mm (17.3") modes: 1920x1080
  API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
    drv: nvidia device: 1 drv: iris device: 3 drv: swrast surfaceless:
    drv: nvidia x11: drv: iris inactive: gbm,wayland,device-2
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics 630 (CFL
    GT2) device-ID: 8086:3e9b
  API: Vulkan v: 1.3.269 layers: 1 surfaces: xcb,xlib device: 0
    type: discrete-gpu driver: nvidia device-ID: 10de:1c20 device: 1
    type: integrated-gpu driver: mesa intel device-ID: 8086:3e9b
Audio:
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA GP106 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: speed: 8 GT/s lanes: 8 bus-ID: 01:00.1 chip-ID: 10de:10f1
    class-ID: 0403
  API: ALSA v: k6.6.5-3-MANJARO status: kernel-api with: aoss
    type: oss-emulator
  Server-1: JACK v: 1.9.22 status: off
  Server-2: PipeWire v: 1.0.0 status: off with: 1: wireplumber status: off
    2: pipewire-alsa type: plugin
  Server-3: PulseAudio v: 16.1 status: active
Network:
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlan0 state: down mac: <filter>
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: speed: 2.5 GT/s lanes: 1
    port: 3000 bus-ID: 3b:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: docker0 state: down mac: <filter>
  IP v4: <filter> scope: global broadcast: <filter>
  WAN IP: <filter>
Bluetooth:
  Message: No bluetooth data found.
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 2.05 TiB used: 490.62 GiB (23.3%)
  ID-1: /dev/sda vendor: Seagate model: ST2000LM007-1R8174 size: 1.82 TiB
    speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter> fw-rev: SDM2
    scheme: GPT
  ID-2: /dev/sdb vendor: SK Hynix model: SC311 SATA 256GB size: 238.47 GiB
    speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0P10 scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / size: 44.06 GiB used: 30.84 GiB (70.0%) fs: ext4 dev: /dev/sdb2
    label: N/A uuid: a3d17ce4-9aaf-437d-a73a-439edc842272
  ID-2: /boot/efi size: 299.4 MiB used: 292 KiB (0.1%) fs: vfat
    dev: /dev/sdb1 label: EFI uuid: 45D5-9BC5
  ID-3: /data size: 549.31 GiB used: 286.94 GiB (52.2%) fs: ext4
    dev: /dev/sda3 label: Data uuid: 27bc111f-0627-4f8e-aad9-f5b08eb60e14
  ID-4: /home size: 172.33 GiB used: 32.53 GiB (18.9%) fs: ext4
    dev: /dev/sdb3 label: N/A uuid: f19fe205-c411-40ff-b63a-165435acb85d
  ID-5: /music size: 732.29 GiB used: 54.87 GiB (7.5%) fs: ext4
    dev: /dev/sda1 label: Music uuid: 04b74089-4a64-43f4-afa9-ffea7b6cb0b5
  ID-6: /var size: 91.11 GiB used: 35.87 GiB (39.4%) fs: ext4 dev: /dev/sda4
    label: var uuid: a51c81a4-a4b9-422e-912f-e08a5c8d0d31
  ID-7: /video size: 457.28 GiB used: 49.58 GiB (10.8%) fs: ext4
    dev: /dev/sda2 label: Video uuid: 821ea29a-ea1f-4aeb-8658-e293f9046d4b
Swap:
  ID-1: swap-1 type: partition size: 17.08 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sdb4 label: N/A uuid: 1a692f9b-337c-4cfa-81e9-a514be6aa511
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: hi-speed hub with single TT ports: 16 rev: 2.0
    speed: 480 Mb/s lanes: 1 chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:2 info: ASUSTek ASUS ROG GAMING MOUSE GX900
    type: mouse,keyboard driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s lanes: 1 power: 100mA chip-ID: 0b05:1795 class-ID: 0301
  Device-2: 1-5:3 info: Realtek Integrated Webcam type: video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s lanes: 1
    power: 500mA chip-ID: 0bda:568a class-ID: 0e02 serial: <filter>
  Device-3: 1-6:4 info: Realtek RTS5129 Card Reader Controller
    type: <vendor specific> driver: rtsx_usb,rtsx_usb_ms,rtsx_usb_sdmmc
    interfaces: 1 rev: 2.0 speed: 480 Mb/s lanes: 1 power: 500mA
    chip-ID: 0bda:0129 class-ID: ff00 serial: <filter>
  Hub-2: 2-0:1 info: super-speed hub ports: 8 rev: 3.1 speed: 10 Gb/s
    lanes: 1 chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  Src: lm-sensors+/sys Message: No sensor data found using /sys/class/hwmon
    or lm-sensors.
Info:
  Processes: 346 Uptime: 38m wakeups: 0 Init: systemd v: 254
  default: graphical Compilers: gcc: 13.2.1 clang: 16.0.6 Packages: 2097
  pm: pacman pkgs: 2090 pm: flatpak pkgs: 7 Shell: Bash v: 5.2.21
  running-in: konsole inxi: 3.3.31
1 Like

I have been investigating something similar on XFCE, also mentioned here:

Xfce4 black screen with cursor when switching between users

After 2023-12-01 I can not get in to a timed out session

can you see if it might be the same problem ?

1 Like

Thanks, but I don’t see how those links can resolve the issue in my case.

Reinstalling Plasma did not help.
Does anybody know what is the root cause of this problem: Manjaro kernel, kde, sddm ? :question:

It looks like this or similar problems have been an ongoing issue for you for at least 18 months.

https://forum.manjaro.org/u/RomanPerekhrest/activity/topics

My guess is that whatever you’ve done to workaround these issues is fragile and gets broken by updates. So start by describing exactly what that is. Presumably you’ve made changes to sddm and/or X configuration?

No. I didn’t touch those yet.

The post’s description of this issue is quite comprehensive and obvious.

I don’t know who is responsible for this bad issue: Manjaro, Nvidia, or both, but that’s completely untalented development. This issue is breaking my work every single day, this issue makes many users suffering.
Forgive my frankness.

I understand your frustration but you are barking up the wrong tree.
It is a common issue where Nvidia is the most likely to blame.

Any Idea why it seems it only affects only some nvidia cards, because some claim, they got no problems.

I guess, after my posts, i had the problem already once at Feb '23, then it was fixed with Kernel 6.1.62-1, but came back with Kernel 6.1.69-1.
I tried to downgrade 6.1.62-1 but it caused to much problems.

I got now after suspend only a blackscreen with a visible mouse cursor, at 6.6 i got a total black screen.
But still, tty works. So it seems, something is still loading.
I have to end the session at F7 with ctrl-alt-backspace, at least, my settings are then restored after login again.
I also changed at powermanagement at system from powersavemode from sleep to suspend, what helps now for 2 out of 3, that XFCE loads normal again.
Sometime even i got the black screen with mouse pointer and like one minute later it loads/shows the desktop again.
Not sure, if its related to the nvidia modules or XFCE because with the gnome desktop, suspend seems works normal.
Where i also can not say, if its the new installation from gnome, and the problem vanish vice versa from Gnome to XFCE after installing a new desktop, when someone got the black screen problem under Gnome.

I’ve also been experiencing (from time to time) similar histories with “black screen + mouse pointer” on KDE Plasma.

I’d try that, but unfortunately we don’t have such an option “suspend” in Plasma power-management options.


And the implied issue has never been emerging from kernel switches, but after newly installed system packages updates.
If I was fairly certain that the root of the issues is Nvidia, I wouldn’t even buy this laptop with it.

@RomanPerekhrest
Anyhow i assume the problems too at some software setting, maybe it is only a problem with rights.
I have 2 systems where i can compare, one updated, one still at the old stage. My problems started also after 2 updates where it did update some software plus kernels. So i dont really know where to look closer, because i already try what i can find.

Your powersaving mode should be configurable here.
https://userbase.kde.org/System_Settings/Power_Management
It shows there hibernate, not sure, what else is there, i stopped using KDE.

I found another page at XFCE, what said, delete (or rename for now) .cache/sessions, that it get recreated, but i was not sure, if it really helps, so i did not mention it, maybe worth a try.

And with a periodicity of few days it resumes with just black screen (no mouse pointer, nothing), and all attempts to switch another TTY (ctrl+alt+F) has no effect. Have to only press power off.
With the same periodicity it crashes with blinking Caps-Lock on resume.

Hopefully this issue might be fixed with the upcoming Plasma 6 release on 28th February:

This week in KDE: Inching closer – Adventures in Linux and KDE

Fixed an issue that could cause the screen to end up black with only a movable cursor when you wake your system from sleep while using an NVIDIA GPU with its proprietary drivers (David Redondo, link)

Interesting, I’ll look froward for that update.
Did you have similar issues on AMD Radeon card using Kde Plasma?

No - I haven’t experienced any issues at all since I bought my AMD mini-PC 4 months ago & installed Manjaro KDE on it. Plasma has been very reliable on this machine.

A plenty of issues I got with KDE Plasma says that it’s not a good choice in terms of ubiquitous support.
Someone criticize Gnome for some bugs, someone criticizes Xfce for its “excessive” simplicity.
It’s hard for me to choose DE which is more stable but at the same time as much as versatile as Plasma.