Unable to log in after computer lock

Desktop pc.
OS :Manjaro Linux x86-64
DE : Cinnamon 5.4.8
CPU :AMD Ryzen 5 3600 (12) @ 3.600GHz
GPU:RX550 4go
RAM :16go
No fingerprint reader
Certain to be on the correct keyboard layout (fr) and not to have caps lock activated.
User: root and me

Hello everyone, I am writing here because I have had a problem for some time that sometimes, not all the time, occurs when my machine gets locked. And I will need a hand to fix this.

My concern is this: I’m sure I’m entering the correct password but it’s being counted as wrong. I tried via virtual keyboard to be sure but no there too it is counted as fake.
So I went to a TTY to try, again it was counted wrong, finally it was especially indicated to me that following 3 consecutive errors I was put on hold for 3 minutes.
After these 3 minutes I try again, sometimes it passes and sometimes it starts telling me that my password is wrong. In the last case I reboot my machine to solve the problem and not have to wait.

Miscellaneous informations that may be helpful:
About a month ago I wanted to change my password via Cinnamon’s built-in option, I couldn’t do it that way, in fact the field where I had to enter the current password told me that the password was wrong (though I’m 100% sure I’m entering the correct one), so I proceeded via CLI with passwd {$myuser}, which was successful. I then had to modify it in kwallet and gnome keyring (yes I have both because of Keyweb, which is not a problem on my manjaro KDE machine).

I have never managed to install the virtualbox-guest-ext package from a file because virtualbox asks me for a password which is constantly false when I return. My workaround was to install this pack from the AUR repositories.

This bug(?) also happened to me before upgrading to Cinnamon 5.4.

My research first led me to a problem with PAM and results that were at least a year old. Then to a problem related to a fingerprint reader, which I do not have on my machine but the symptoms stick surprisingly well.

As you can imagine I’m a little lost, I really thank you in advance for your help and your time.

In French

Bonjour à tous et toutes, je viens écrire ici, car j’ai depuis quelque temps un problème qui survient parfois, pas tout le temps, lorsque ma machine se voit verrouiller. Et j’aurai besoin d’un coup de main pour réparer ça.

Mon souci est le suivant : je suis sûr d’entrer le bon mot de passe mais celui-ci est compté comme faux. J’ai essayé via le clavier virtuel pour être sûr de sûr, mais non là aussi il est compté comme faux.

Je suis donc passé sur un TTY pour essayer, là aussi il m’est compté faux, enfin il m’est surtout indiqué que suite à 3 erreurs consécutives je suis mis en attente 3 minutes.

Au bout de ces 3 minutes je ré-essais, parfois ça passe et parfois cela recommence à me dire que mon mot de passe est faux. Dans le derniers cas je reboot ma machine pour résoudre le problème et ne pas avoir à attendre.

Divers informations pouvant être utiles :

Il y a cela un mois environ j’ai voulu modifier mon password via l’option intégrée de Cinnamon, je n’ai pas pu le faire ainsi, en effet le champ où je devais entrer le password actuel me disait que le mot de passe était faux (je suis pourtant sûr à 100 % d’entrer le bon), j’ai donc procédé via CLI avec passwd {$myuser}, ce qui à été un succès. J’ai eu ensuite à le modifier dans kwallet et gnome keyring (oui j’ai les deux à cause de Keyweb, ce qui ne pose pas de souci sur ma machine manjaro KDE).

Je n’ai jamais réussi à installer depuis un fichier le pack virtualbox-guest-ext car virtualbox me demande un mot de passe qui est constamment faux quand je rentre. Mon contournement a été d’installer ce pack via les dépôts AUR.

Ce bug(?) m’est aussi arrivé avant la mise à niveau vers Cinnamon 5.4.

Mes recherches m’ont mené dans un premier temps vers un problème avec PAM est des résultats ayant au moins un an d’anciennetés. Puis vers un problème lié à un lecteur d’empreinte digitale, que je n’ai pas sur ma machine mais les symptômes collent étonnamment bien.

Comme vous pouvez vous en doutez je suis un peu perdu, je vous remercie vraiment par avance pour votre aide et votre temps.

Just to establish some confidence:

When you go to TTY, you can type … whatever (instead of your username)
and see it

Can you confirm that when you type your password, what appears on screen is actually your password?

This is to check whether there is some locale or keyboard layout issue leading to you thinking you are typing one thing, while the computer sees another …

My username displays correctly and flawlessly, but I’m not using characters that switch between FR and US keyboard layouts. I’m pretty sure it’s good, but if in doubt next time I’ll try typing qwerty to see.
The password is not displayed in TTY and CLI, so I have no way of knowing.

Out of curiosity and since you just made me think about it, I just tested, just in case, changing my password via the Cinnamon menu by copying/pasting my current password from a text file to the current password field the result is still wrong password.

just type your password instead of your name so you can see whether what you type is actually what appears on screen

now I’m confused - if you are doing this from within your DE (Cinnamon)
you obviously can log in.
which is it?
Can you can you not log in?

That’s the thing, I can connect to my session when starting the pc, it’s only sometimes that I find myself blocked at the door after locking my session with CTRL+ALT+l
Most of the time I can unlock it, but sometimes, and I’m sure I’m typing the correct password because I tried to enter my password using the virtual keyboard, I can’t log in c That’s why I went to check on TTY if I could use it to connect to the CLI, especially to be able, the first times, to restart my machine properly from the CLI.
Where it’s even more suspicious, as I said, is that certain parts of my distro / apps tell me that my password is wrong when no, I used it just now to log in to my session and run stuff with sudo.

I think I have seen similar posts/similar issues here on this board.
Perhaps you search for them and see whether these provide helpful info.
I do not know how to proceed.

Yes I also think that I will have to scratch in depth the various posts on the subject mentioned above. :confused:

On the other hand I have new, I took a break of 40-45 minutes, nobody could have access to my machine while returning and trying to connect me the error and returned.
After a single try I switched to TTY to try your suggestion, my password is correctly written. I enter everything but get thrown out because 3 consecutive errors. Except I haven’t done that many tries, so I’m assuming something is trying to log in or counting as a login attempt, which I’ve seen pass for fingerprint readers that would do a call regularly counting as a connection attempt with bad identifier. Except I don’t have a fingerprint reader and it’s a machine I built myself so I don’t think my MB’s bios has anything affiliated with that type of reader.

perhaps this works even if you don’t even have a fingerprint sensor - I don’t know:

sudo pacman -R fprintd

Don’t know whether you have it installed - but this removes it if you do have it.