Unable to lock database Failed to synchronize databases


If someone informed could spend a little bit of time to tell me how to deal with this message I’ve been getting lately when I update the system, it would be much appreciated.

What I tried :

A reply to this post informed me that it means that “another process is running.”

The suggested command returns this :

sudo rm /var/lib/pacman/db.lck  :heavy_check_mark:
[sudo] password for jorgecpd:
rm: cannot remove ‘/var/lib/pacman/db.lck’: No such file or directory

I didn’t try the other command, because in the end I do not know what I am doing.
What’s the correct way of dealing with this? What do you need to know in order to answer this?

check if you have the db.lck in this location:
if yes delete it

1 Like

@brama thank you.

check if you have the db.lck in this location:
if yes delete it

I found the file using Kfind. I deleted it, and now Pamac is pulling 2 Gb of updates and removing a lot of python packages I had to install for Qgis, grass and saga (tools for Qgis). I hope nothing breaks!

I was just about to ask that same question on the forum, but I was informed you had already given an answer. Thanks!

Thinking back, I remember I had this problem once before when I ran Manjaro a few years back.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.