Unable To Launch OBS

I’ve had this strange issue with OBS since I had installed a second GPU as pass-through for VMs.
I had followed this guide up to the section named " Setting up an OVMF-based guest virtual machine".

My main GPU is a RTX 3070, while the pass-through GPU is a GTX 970.

I had an issue where when I attempted to launch OBS through GUI or the command line using flatpak run com.obsproject.Studio I would be given the error pop-up of

Failed to initialize video. Your GPU may not be supported, or your graphics drivers may need to be updated.

Before the recent update to the 515.48.07 drivers for nvidia, when I tried using the command line to launch OBS it threw the same error, but after a reboot it no longer threw that error.
Unfortunately, it seems like the update to that driver has made my system throw that error again.
I’m assuming it may be OBS or my system incorrectly recognizing the 970 drivers for the 3070.

This is the log file produced when attempting to launch OBS.

14:16:45.694: CPU Speed: 3600.000MHz
14:16:45.694: Physical Cores: 8, Logical Cores: 16
14:16:45.694: Physical Memory: 31900MB Total, 19672MB Free
14:16:45.694: Kernel Version: Linux 5.15.46-1-MANJARO
14:16:45.694: Distribution: "KDE Flatpak runtime" "5.15-21.08"
14:16:45.694: Session Type: x11
14:16:45.694: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
14:16:45.695: Qt Version: 5.15.4 (runtime), 5.15.3 (compiled)
14:16:45.695: Portable mode: false
14:16:45.723: OBS 27.2.4 (linux)
14:16:45.723: ---------------------------------
14:16:45.734: ---------------------------------
14:16:45.734: audio settings reset:
14:16:45.734: 	samples per sec: 48000
14:16:45.734: 	speakers:        2
14:16:45.737: ---------------------------------
14:16:45.737: Initializing OpenGL...
14:16:45.739: ARB_GLX_create_context not supported!
14:16:45.739: Failed to create context!
14:16:45.739: device_create (GL) failed
14:16:45.739: Failed to initialize video.  Your GPU may not be supported, or your graphics drivers may need to be updated.
14:16:47.043: Freeing OBS context data
14:16:47.046: == Profiler Results =============================
14:16:47.046: run_program_init: 1444.42 ms
14:16:47.046:  ┣OBSApp::AppInit: 1.646 ms
14:16:47.046:  ┃ ┗OBSApp::InitLocale: 0.734 ms
14:16:47.046:  ┗OBSApp::OBSInit: 60.018 ms
14:16:47.046:    ┣obs_startup: 16.047 ms
14:16:47.046:    ┗OBSBasic::OBSInit: 4.733 ms
14:16:47.046:      ┣OBSBasic::InitBasicConfig: 0.073 ms
14:16:47.046:      ┣OBSBasic::ResetAudio: 0.072 ms
14:16:47.046:      ┗OBSBasic::ResetVideo: 4.553 ms
14:16:47.046: obs_hotkey_thread(25 ms): min=0.037 ms, median=0.133 ms, max=6.529 ms, 99th percentile=6.529 ms, 100% below 25 ms
14:16:47.046: audio_thread(Audio): min=0.005 ms, median=0.005 ms, max=0.01 ms, 99th percentile=0.01 ms
14:16:47.046: =================================================
14:16:47.047: == Profiler Time Between Calls ==================
14:16:47.047: obs_hotkey_thread(25 ms): min=25.106 ms, median=25.222 ms, max=31.587 ms, 98.0769% within ±2% of 25 ms (0% lower, 1.92308% higher)
14:16:47.047: =================================================
14:16:47.047: Number of memory leaks: 307```

It is fully normal that after upgrading the nvidia driver you need to reboot.

I expected as much. I have rebooted my system after the update, however the error still persists.

I tried a few things to check if I could troubleshoot this.
I checked inside of nvidia-settings to see if there was anything amiss, but it does look like my system detects my RTX 3070 as the only card.

I have also confirmed that I am running the 515.48.07 drivers.
I have tried reinstalling the drivers and rebooting.

Launching OBS still yields the same error.

Just note, that flatpak has its own ecosystem. It has its own nvidia libs.

Check what runtimes are installed:

flatpak list --runtime --columns=application

Run an update:

flatpak update

List active OpenGL Driver:

flatpoak --gl-drivers   

Repair applications:

flatpak repair

Check glxinfo:

flatpak install org.freedesktop.Platform.GlxInfo
flatpak run org.freedesktop.Platform.GlxInfo | grep "OpenGL renderer" 

I thought that was the case, that’s why I was confused as to why OBS would throw such an error after a driver update.

This is what comes up when I run the check on runtimes.


There does seem to be updates available for org.freedesktop.Platform.GL.nvidia-515-48-07

When installing glxinfo I was prompted to update the nvidia library as well, I have and the results of running is
OpenGL renderer string: NVIDIA GeForce RTX 3070/PCIe/SSE2

Everything looks to be in order and OBS launches properly!
Seems like I may need to update libraries everytime there’s a driver update from Nvidia.

Thanks again megavolt for your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.