Unable to launch nvidia-settings

Hello, after updating to the 450.xx drivers back in august for nvidia i am unable to lauch the nvidia settings app ( this is the first time i tried run it since the update in august ) ,
So i tried from the terminal it show this error

NB: i have an optimus laptop. it is only one screen/display i am using ( the laptop display),i don’t have the CUDA package installed
the /etc/X11/xorg.conf.d/90-mhwd.conf file is empty it just shows
#Generated ny mhwd..........

➜ ~ nvidia-settings -V
WARNING: NV-CONTROL extension not found on this Display.
ERROR: Unable to load info from any available system

Here is other necessary info if needed

➜  ~ inxi -G
Graphics:  Device-1: Intel UHD Graphics 620 driver: i915 v: kernel
           Device-2: NVIDIA TU117M [GeForce GTX 1650 Mobile / Max-Q] driver: nvidia v: 450.66
           Device-3: IMC Networks Integrated Camera type: USB driver: uvcvideo
           Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: nvidia resolution: 1920x1080
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 20.1.7

➜  ~ mhwd --listinstalled
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-450xx-prime            2019.10.25               false            PCI
     video-modesetting            2020.01.13                true            PCI

Warning: No installed USB configs!

i also tried running prime run on glxinfo this is the error

➜  ~ prime-run glxinfo
name of display: :0
X Error of failed request:  BadValue (integer parameter out of range for operation)
  Major opcode of failed request:  152 (GLX)
  Minor opcode of failed request:  24 (X_GLXCreateNewContext)
  Value in failed request:  0x0
  Serial number of failed request:  39
  Current serial number in output stream:  40

prime-run works with dolphin and handbrake but not obs and kdenlive