Unable to install WINE

Hey, uhh
so, I’m trying to install Wine, but I’m running into a few issues.
First thing I tried was to download the .tar.xz file on WineHQ and follow the guide provided in the README, however I already run into a problem in the first step:

$ ./configure
checking build system type… x86_64-pc-linux-gnu
checking host system type… x86_64-pc-linux-gnu
checking whether make sets $(MAKE)… no
checking for gcc… no
checking for cc… no
checking for cl.exe… no
configure: error: in /home/minit/Downloads/wine-6.0.1': configure: error: no acceptable C compiler found in $PATH See config.log’ for more details

and I am unable to proceed with make.

Next thing I tried was $ sudo pacman -S wine winetricks wine-mono wine_gecko, which ended with error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded.
after having output 404 errors for several packages, leaving me without a wine installation still. Please advise.

wine is in the repo

sudo pacman -Syu wine

Try the packages one at a time - to see which one generates the error.

If you get 404 - you should update your mirrorlist and run a full system sync.

If you try to compile wine from source - you will need the meta package base-devel installed - add the -needed flag as some package may already be installed.

sudo pacman -Syu base-devel --needed

“wine is in the repo” sometimes solutions are just that easy … :sweat_smile: That did the job, thank you.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.