Unable to install video-nvidia-340xx with linux58 kernel

Hello Manjaro community!

I’ve installed manjaro-kde-20.1.1 on an old macbook pro (13" mid-2010 MBP), and I like it very much accept since the beginning I had some weird graphics issues when changing between windows (it flickers sometimes and only makes parts of the newly opened window visible when I move my cursor over it). I figured it had to do with my NVIDIA GPU. Running ‘mhwd -li’ shows that ‘video-linux’, ‘network-broadcom-wl’ and ‘video-modesetting’ are installed, so I thought changing to the proprietary driver ‘video-nvidia-340xx’ might fix it but the driver is no longer supported for my current kernel (‘error: target not found: linux58-nvidia-340xx’). One suggested solution was to install the linux 5.4 kernel and install the driver from that kernel, which I tried, but there was no possibility to enter the GRUB menu and choose this kernel, my laptop only booted to the 5.8 version (read somewhere CAPS and ESC needed to be pressed). I haven’t got ‘linux-latest’ installed (sudo pacman -R linux-latest), so that isn’t the problem either. I also changed the /etc/default/grub file so ‘GRUB_TIMEOUT_STYLE=menu’ and even did grub-install (and there is a /boot/efi partition on my hard drive).
Meanwhile it became impossible to load the login screen (SDDM, I guess?) and now I’m only able to login via TTY2 and than ‘startx’, which works fine but is not a solution.
Is there a way to get the proprietary driver working with the linux5.8 kernel installed? Or does somebody know why I can’t enter the GRUB menu?
I’m not a total newbie in the world of linux but explicit suggestions would be appreciated! It’s my first post and I’ve read a lot of good things about the manjaro community (which is part of why I chose the distro), so I my hopes are up!


(and use 5.4)

This doesn’t work either, I tried holding shift and pressing it repeatedly without luck. My system is in efi not BIOS so maybe that is causing it, but also Esc doesn’t work. Is there a way to check my grub is configured correctly? This is the output of the efibootmgr:

$ efibootmgr -v
BootCurrent: 0002
BootOrder: 0002,0001,0000,0080
Boot0000* ubuntu HD(1,GPT,f551177a-8134-4192-9e62-a82a9eecb2eb,0x800,0x100000)/File(\EFI
Boot0001* Manjaro HD(1,GPT,5f9ec9ef-1176-a84e-8213-3375b75c9676,0x1000,0x96000)/File(\EFI
Boot0002* GRUB HD(1,GPT,5f9ec9ef-1176-a84e-8213-3375b75c9676,0x1000,0x96000)/File(\EFI\GRUB\gr
Boot0080* PciRoot(0x0)/Pci(0xa,0x0)/Sata(0,0,0)/HD(2,GPT,00003d39-0e1f-0000-6b62-0000387e
Boot0082* PciRoot(0x0)/Pci(0xa,0x0)/Sata(0,0,0)/HD(2,GPT,00003d39-0e1f-0000-6b62-0000387e
BootFFFF* PciRoot(0x0)/Pci(0x6,0x1)/USB(3,0)/HD(1,MBR,0x0,0x5cbcf8,0x2000)/File(\EFI\BOOT

I fixed the problem by removing linux58, only keeping kernel 5.4 (don’t really know how ‘risky’ this procedure was) and it worked! I updated my mirrors and installed the proprietary nvidia drivers. I’m still wondering why I couldn’t get into the GRUB menu but this might have to do with Apple and not Manjaro.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.