Unable to install package from downloaded file

I’m unable to install local files. I’m able to use the pacman and pamac package managers to install packages from repositories and get updates however, whenever I try to do so with a local file I get
error: missing package metadata in “x”.tar.gz
error: “x”.tar.gz’: invalid or corrupted package

I’m not too familiar with checksum so I don’t run them often but I ran one on a file a tried to install and it did not seem to be corrupted

at least half of the (ever so important) context is missing - please elaborate!

Hi, @Molefi ! Welcome to community!

You could provide details what is going on to help people to understand you in details.

at least:

  1. how you did check hash sum?

  2. what makes you to conclude, that the file is not corrupted?

  3. what exact terminal input and output are? terminal excerpts would be helpful.

  4. may be to switch to exact package to go into details?

  5. how did you do the installation?

  6. were other packages installed well via the same procedure?

Welcome to the forum! :wave:

That’s a tarball (compressed file like zip or rar), not a package file (like pkg.tar.xz or pkg.tar.zst). Most likely you can extract it somewhere and run it. However, without knowing what program you want to use no one can help you.

I used gtkhash on a download of eclipse and the and the values matched so I assume that means that the downloaded file is not corrupted

to install the packages is used commands
sudo pacman -U eclipse-inst-jre-linux64.tar.gz
sudo pacman -U android-studio-2022.1.1.19-linux.tar.gz

both files are in the same directory, and my terminal is opened in the same directory as the files and for both I get error messages:
loading packages…
error: missing package metadata in android-studio-2022.1.1.19-linux.tar.gz
error: ‘android-studio-2022.1.1.19-linux.tar.gz’: invalid or corrupted package

loading packages…
error: missing package metadata in eclipse-inst-jre-linux64.tar.gz
error: ‘eclipse-inst-jre-linux64.tar.gz’: invalid or corrupted package

I’ve I run sudo pacman -Syu to install a few packages with no issues as well as pamac build

I hope that’s enough detail

It’s correct those packages aren’t corrupted but you still get the error because they are invalid, they are not packages you can install with pacman/pamac. Follow the instructions @Yochanan gave you.

For example for eclipse, when you extract it, you’ll see an excutable file called eclipse-inst click it and it will run the installer.

No. As I just mentioned, the .tar.gz compressed archives are not installable packages. You’ll find the instructions for using them on the website you found them on.

FYI, both programs are in the AUR (Arch User Repository). There are several versions, so it’s up to you do decide which one you need.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.