Unable to install mongoDB

Hello there,
I am trying to install mongoDB using the following command:

pamac build mongodb-bin
pamac build mongodb-tools-bin
pamac build mongodb-compass

mongodb-compass downloaded perfectly but when I try to download mongodb-bin, it gives me the following error:

Error: Failed to commit transaction:
conflicting files:

  • openssl-1.1: /usr/lib/libcrypto.so.1.1 already exists in filesystem (owned by openssl)
  • openssl-1.1: /usr/lib/libssl.so.1.1 already exists in filesystem (owned by openssl)

Then I thought maybe mongodb-bin is already installed and I went into the directory to makepkg it but then I got the following error:


Now I deleted mongoDB-bin but I still get the initial error:


I tried deleting libcrypto.so.1.1 but I can’t delete it either.
not sure what to do rn

Always update your system before you try to install new packages. If you belive you are up to date, make sure you are using a mirror that works, because the OpenSSL package is since a long time at version 3 and yours is clearly not.

1 Like

Images to describe your issues is a no-go - they are useless in the forum search engine.

Paste the console output instead.

Ensure your system is fully up-to-date.

Check if you should use AUR packages

if [[ $(pacman-mirrors -G) =~ 'unstable' ]]; then echo 'OK - go ahead'; else  echo 'AUR is no-go';  fi

If you get a no-go from above command switch to unstable branch

sudo pacman-mirrors -aS unstable && sudo pacman -Syyu