Unable to install Manjaro xfce

What I did :-
I have download the Manjaro xfce (Minimal provides a basic desktop environment with no additional software packages pre-installed) , checked the sha1, developer GPG key, and I found no broker/modified file. So I created a bootable dvd and a free space to dual boot manjaro with ubuntu (I just wanted to try how much fast and efficient it is), I select the manjaro boot with open source and it booted into live manjaro, Then I installed the manjaro in 1 drive (I didn’t created a swap partition as it wasn’t letting me do it, So rather I created a ext4 partition first and just Installed in it as, Last page came I rebooted and no grub was there so I booted with a ubuntu 20.4 LTS live and boot repaired it. Now the grub was there and I can see Manjaro written.

Problem :- when I selected the option Manjaro 64x this showed up and stays on this screen forever
what can I be doing wrong here?

Thanks :slight_smile:

20210828_092252|666x500, 50%

It says I cannot embed media in post so I am posting it here

Ubuntu Live ISO would not be capable of repairing Manjaro GRUB

I suggest you boot from a Manjaro live ISO, and login to installed OS

sudo manjaro-chroot -a

and update grub from within installed Manjaro

sudo update-grub

GRUB/Restore the GRUB Bootloader - Manjaro

1 Like

Manjaro grub showed up problem didn’t solved.
Tried on a virtual machine, It installs takes and space but when I reboot it again goes to live boot :frowning:

In that virtual machine, you have to “eject” the ISO file you used to install from.
(remove it - as it is no longer needed - you used it to install the system and there is now no reason for it being there anymore)

Or change the boot order so the VM boots off of the virtual disk you just installed to.
If you change nothing, it will keep booting from the ISO first.

You probably use Virtualbox - Gnome Boxes and Virt-Manager will do this for you.

… it’s just like on a real PC -
remove the installation media once you have used it
or make sure that the PC does not (try to) boot from that installation medium as it’s first option
but from the hard disk you just installed to instead

1 Like

Thank you so much It worked on the virtual box! But I don’t know whats the problem in the dual boot I think I am gonna reinstall it

I tried again but same thing is happening
And when I try to do sudo manjaro-chroot -a it gives me 2 options when I choose choose either of them(tried with both) then I run the command sudo update-grub , it does it thing and then it doesn’t change the grub to manjaro one, it stays to linux mint grub (I installed linux mint and manjaro for 2nd time)
How to solve this? Pls tell me