Unable to install Manjaro KDE with manual partition setup


I’m trying to install Manjaro KDE on a HP Probook x360 435 G6 with Ryzen 5800U.

I would like to manually create partitions and to use an extra partition for my home directory.
Unfortunately, the only configuration that results in a working system is the automatic installation with only one partition. As soon as I try to manually create the partitions, I end up with a system without any boot loader even though I created an EFI partition, marked as boot and mounted to efi/boot.

The installer works without error message, but afterwards the system is either unable to find any bootloader or ends up in grub rescue mode. In the second case, it’s impossible to manually fix the grub configuration since grub cannot deduce the file system for the efi partition. I have no clue why some tries to install manjaro give the first result and some yield the second.

SecureBoot is disabled and the laptop does not seem to offer a legacy/bios option instead of uefi.

Any ideas?

Welcome to the forum!

Just one, and it may not even apply in your case, but I distinctly remember that back when I installed Manjaro ─ now well over two years ago ─ I had to explicitly select the partition table as GPT when doing manual partitioning, and some UEFI versions don’t work well with an MBR-style partition table.

If all else fails, then you can download one of the standalone GParted images, make it into a bootable USB drive or optical drive, and pre-partition your drive as you would want it. Then reboot with the Manjaro installer and tell it to use the existing partitions.

Do however make sure that… :arrow_down:

  1. the machine does boot in UEFI mode, even with the GParted image; and…
  2. the partition table is GPT, not MBR.

I recently installed 21.1.1 KDE and manual partitioning worked out as expected. But there was indeed a problem with manual partitioning in the previous release.

See this:

1 Like

I had once faced a similar problem during manual partition. Manjaro installed fine, but did not boot after restart (No grub or efi partition in boot-menu!).
Then I booted from the live media, installed gparted and found that the efi partition had somehow the flag msftdata. Changed the flags to boot and esp only in gparted; chrooted into the installation and reinstalled grub.

grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --recheck

After reboot all was working!
(That was Manjaro 21.07, btw)

1 Like

Thank you for your comments!
The link from ralm helped:
First, I installed Manjaro with automatically created partitions. Then I reinstalled Manjaro, using the automatically created efi partition and manually created partitions for everything else. The important trick to make this solution work was not to delete the automatically created system partition to make space for my individual setup but to shrink it.

I can only speculate about the reasons, but the automatically created partition setup has 1MB of free space in front of the efi partition. If I shrink the automatically created partition, the installer keeps 1 MB of free space in front of the efi partition. If I delete it, this 1MB is included in the total free space in which I then create the new partitions. Perhaps that’s the important difference… but again, only speculation.

If a developer for the installer needs some information to look into this, feel free to ask - I will do my best to provide help.

Can you provide the output of the following commands:

sudo efibootmgr -v
sudo lsblk -f
sudo blkid
sudo fdisk -l

That should be enough to maybe understand what happened

PS: If your issue is solved, mark one of the post as the solution. Even if it is your own one

1 Like


please find the requested outputs below. Of course, they belong to the running system.

efibootmgr -v (The SanDisk is the usb stick I used for the installation)

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0003,0002,0001,0004
Boot0000* Manjaro       HD(1,GPT,85e57868-ebdf-684e-bafe-b9c73aa24ca8,0x1000,0x96000)/File(\EFI\Manjaro\grubx64.efi)
Boot0001  Network Boot:IPV4     PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(4,0)/MAC(3c18a0c5bbbc,0)/IPv4(,0,0)N.....YM....R,Y..(..ISPH
Boot0002* SAMSUNG MZVLQ512HALU-000H1-S4UHNX1R576201     PciRoot(0x0)/Pci(0x2,0x4)/Pci(0x0,0x0)/NVMe(0x1,00-25-38-A5-11-B7-43-93)N.....YM....R,Y.....ISPH
Boot0003* SanDisk Cruzer Blade 4C530303211226114263     PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x4)/USB(1,0)N.....YM....R,Y.....ISPH
Boot0004  Network Boot:IPV6     PciRoot(0x0)/Pci(0x8,0x1)/Pci(0x0,0x3)/USB(4,0)/MAC(3c18a0c5bbbc,0)/IPv6([::]:<->[::]:,0,0)N.....YM....R,Y..0..ISPH

lsblk -f

NAME        FSTYPE FSVER LABEL    UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
├─nvme0n1p1 vfat   FAT32 NO_LABEL 0A4E-6409                             299,1M     0% /boot/efi
├─nvme0n1p2 ext4   1.0            96491b1c-1a84-4af8-86c7-91eb63be4b42  103,8G    10% /
└─nvme0n1p3 ext4   1.0            2445c88b-e25c-471f-bd33-b1f181ac527e  226,7G     0% /home


/dev/nvme0n1p3: UUID="2445c88b-e25c-471f-bd33-b1f181ac527e" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="85ef3990-b5a5-1446-b170-a22e8fde13b1"
/dev/nvme0n1p1: LABEL_FATBOOT="NO_LABEL" LABEL="NO_LABEL" UUID="0A4E-6409" BLOCK_SIZE="512" TYPE="vfat" PARTUUID="85e57868-ebdf-684e-bafe-b9c73aa24ca8"
/dev/nvme0n1p2: UUID="96491b1c-1a84-4af8-86c7-91eb63be4b42" BLOCK_SIZE="4096" TYPE="ext4" PARTUUID="e636203b-e989-fb46-868b-6e5b72ab69da"

fdisk -l (fdisk decided to speak german, regardless of the system language. I hope the information is clear, regardless of the language. Otherwise, I can try to convince fdisk to speak english :wink: )

Festplatte /dev/nvme0n1: 476,94 GiB, 512110190592 Bytes, 1000215216 Sektoren
Festplattenmodell: SAMSUNG MZVLQ512HALU-000H1              
Einheiten: Sektoren von 1 * 512 = 512 Bytes
Sektorgröße (logisch/physikalisch): 512 Bytes / 512 Bytes
E/A-Größe (minimal/optimal): 512 Bytes / 512 Bytes
Festplattenbezeichnungstyp: gpt
Festplattenbezeichner: 55FA9457-7CD5-4944-B927-6ED064E21FCA

Gerät             Anfang      Ende  Sektoren  Größe Typ
/dev/nvme0n1p1      4096    618495    614400   300M EFI-System
/dev/nvme0n1p2    618496 262762495 262144000   125G Linux-Dateisystem
/dev/nvme0n1p3 262762496 774762495 512000000 244,1G Linux-Dateisystem

I have to admit, that I don’t see anything out of order in those outputs.

The only thing that can come to my mind then, is that you are using the 21.0.7 ISO, where there is a bug in the manual mode that can prevent the correct boot of Manjaro

Thanks for your effort, at least I now know that my strange way of installing did not create some kind of unusual configuration that might cause problems down the road.

I checked again, I used the current 21.1.1 KDE ISO, downloaded from the Manjaro homepage on friday… probably black magic ;).

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.