Unable to install Manjaro KDE on eMMC: Install Grub Issue

Tried to install manjaro kde now all I’m getting is this when I install.

When I go to the installer the only options are to manually partition which I have no idea how to do.
This is what my partitions look like after trying to install.

Uh…What are you installing Manjaro on?

Looks like you’re trying to install Manjaro onto an eMMC or something? Not an actual HDD or SSD?

It’s on a laptop and it only gives me one option to install onto.

While in the LiveISO, please type these commands into the terminal, and provide us with the outputs.

inxi -Fza

Please also use ``` before and after the outputs so that it’s easier to read on the forum. You can open up the web browser in the LiveISO to provide us with the info.

  Kernel: 5.9.11-3-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us 
  tz=UTC misobasedir=manjaro misolabel=MANJARO_KDE_202 quiet 
  systemd.show_status=1 apparmor=1 security=apparmor driver=free 
  nouveau.modeset=1 i915.modeset=1 radeon.modeset=1 
  Desktop: KDE Plasma 5.20.4 tk: Qt 5.15.2 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: LENOVO product: 81VS 
  v: Lenovo IdeaPad Slim 1-14AST-05 serial: <filter> Chassis: type: 10 
  v: Lenovo IdeaPad Slim 1-14AST-05 serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0Z91574 WIN serial: <filter> 
  UEFI: LENOVO v: CWCN20WW date: 06/18/2020 
  ID-1: BAT0 charge: 34.0 Wh condition: 34.0/35.0 Wh (97%) 
  volts: 8.6/7.5 model: SMP L19M2PF0 type: Li-poly serial: <filter> 
  status: Full cycles: 24 
  Info: Dual Core model: AMD A6-9220e RADEON R4 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator family: 15 (21) model-id: 70 (112) 
  stepping: N/A microcode: 6006705 L2 cache: 1024 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 6390 
  Speed: 2324 MHz min/max: 1200/1600 MHz boost: enabled 
  Core speeds (MHz): 1: 1798 2: 1740 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Lenovo 
  driver: amdgpu v: kernel bus ID: 00:01.0 chip ID: 1002:98e4 
  Device-2: Realtek EasyCamera type: USB driver: uvcvideo 
  bus ID: 1-1.1:3 chip ID: 0bda:5627 serial: <filter> 
  Display: x11 server: X.Org 1.20.10 compositor: kwin_x11 
  driver: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") 
  s-diag: 414mm (16.3") 
  Monitor-1: eDP res: 1366x768 hz: 60 dpi: 112 
  size: 309x173mm (12.2x6.8") diag: 354mm (13.9") 
  OpenGL: renderer: AMD STONEY (DRM 3.39.0 5.9.11-3-MANJARO LLVM 11.0.0) 
  v: 4.5 Mesa 20.2.3 direct render: Yes 
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 chip ID: 1002:15b3 
  Device-2: AMD Family 15h Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus ID: 00:09.2 chip ID: 1022:157a 
  Sound Server: ALSA v: k5.9.11-3-MANJARO 
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter 
  vendor: Lenovo driver: ath10k_pci v: kernel port: 1100 bus ID: 02:00.0 
  chip ID: 168c:0042 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Qualcomm Atheros type: USB driver: btusb bus ID: 1-1.2:4 
  chip ID: 0cf3:e500 
  Local Storage: total: 62.05 GiB used: 7.10 GiB (11.4%) 
  ID-1: /dev/mmcblk0 model: DA4064 size: 58.24 GiB block size: 
  physical: 512 B logical: 512 B serial: <filter> rev: 0x8 scheme: GPT 
  SMART Message: Unknown smartctl error. Unable to get data. 
  ID-2: /dev/sda type: USB vendor: Generic model: Flash Disk 
  size: 3.81 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 8.07 scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  ID-1: / raw size: N/A size: 2.75 GiB used: 208.6 MiB (7.4%) 
  fs: overlay source: ERR-102 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 45.0 C mobo: 34.0 C gpu: amdgpu temp: 34.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 189 Uptime: 1h 03m Memory: 3.67 GiB used: 1.48 GiB (40.3%) 
  Init: systemd v: 246 Compilers: gcc: N/A Packages: pacman: 1224 
  lib: 332 flatpak: 0 Shell: Bash v: 5.0.18 running in: konsole 
  inxi: 3.1.08```

Theres the inxi -Fza

This needs to be ```, depend on your keyboard, it might be the button the left of 1

loop0          7:0    0  24.4M  1 loop /run/miso/sfs/livefs
loop1          7:1    0 539.3M  1 loop /run/miso/sfs/mhwdfs
loop2          7:2    0   1.6G  1 loop /run/miso/sfs/desktopfs
loop3          7:3    0 656.3M  1 loop /run/miso/sfs/rootfs
sda            8:0    1   3.8G  0 disk /run/miso/bootmnt
├─sda1         8:1    1   2.9G  0 part 
└─sda2         8:2    1     4M  0 part 
mmcblk0      179:0    0  58.2G  0 disk 
├─mmcblk0p1  179:1    0   300M  0 part /tmp/calamares-root-yz0ncesw/boot/efi
├─mmcblk0p2  179:2    0  49.9G  0 part /tmp/calamares-root-yz0ncesw
└─mmcblk0p3  179:3    0   8.1G  0 part 
mmcblk0boot0 179:8    0     4M  1 disk 
mmcblk0boot1 179:16   0     4M  1 disk```

Here is the lsblk

Oh sorry.

Okay, looks like your laptop uses an 64GB eMMC.

Unfortunately, I am not experienced in installing onto eMMCs; hopefully someone else can help.

I am going to update your title from:

Tried to reinstall manjaro kde but all I get is an error can only boot into usb now
Unable to install Manjaro KDE on eMMC: Install Grub Issue

This will hopefully provide more visibility.

Okay thanks for the help.

Actually, one thing we can try is:

In manual partitioning, on the top, there should be something that says something like “Create New Partition Table” or something like that. Select that, then choose GPT, then try to run the installer again

1 Like

Use KDE Partition Manager to delete all partitions (it is already in your Live Image) and try once using Auto Partiton / Erase disk option.
I am assuming you don’t have any other OS in your eMMC…

Your initial error - is because you have booted your system has no more space to write new boot entries.

It is a common error and the simple answer is reboot into the firmware and delete unneeded entries.

What entries you need to delete is entirely your call - you may be better equipped to make the decision after reading this

I tried to delete a boot for windows but the terminal response was Could not delete variable: No space left on device

Select that, then choose GPT, then try to run the installer again

When I do that there are no partitions made so I would need help to setup the partitions so I could try to install.

Both the fat32 and the main stoarge ext4 are locked form editing when I boot from the live image usb.

  • 100 MB, FAT32, mount to /boot/efi
  • Rest of it, ext4, mount to /

Once booted in, make an 8GB swapfile


So should I make the swap partition while I’m in the manuel partition manager or If I’m able to boot in then I make it?

No, make a swapfile once booted in

The installation failed with the same error as before so I think I need to do what linux-aarhus said to do but I don’t fully understand it.

Nevermind I understand

In manuel partitioning it gives me the option to format the partitions or keep the content should I format them?