Unable to install Manjaro as VM on Apple Silicon

Hi, i downloaded the latest Manjaro ARM image (Manjaro-ARM-kde-plasma-generic-23.02.img.xz) and tried to install it as a VM on my M2 Apple Silicon mac, but to no avail.
First i tried with UTM, but it got stuck on the installation screen

Press ESC in 4 seconds to skip startup.nsh or any other key to continue.

When i do i get a Shell> prompt and i don’t know what to do.

Tired with VMWare Fusion and there also I’m stuck at the start, VMWare trying to install over ipv4.

So, what am i doing wrong ? Is it impossible to install the ARM version of Manjaro as a VM on a M2 Mac ?

I haven’t had any success on macBook Pro M1

I know that some has installed arch using Parallels -

The Arch dev Tobias Powalowski https://archboot.com/ made some ISO for booting Arch on Arm - I can boot it on Fusion but I haven’t had time to go in depth with it yet.

But I have the Manjaro branded version of Asahi running - it is very - to say the least - incomplete - and not a production system by any measure.

ok thx for the feedback. Funny that ARM linux of all things doesn’t run on M2, but W11 ARM does !

If installed using parallels - yes.

You can mogrify the Index of /~tpowa/parallels/5.19.x/ vm to run Manjaro.

Manjaro ARM images are made for devices - not VM so there is no ISO to install from.

yea no iso indeed…