Unable to get into KDE desktop from LiveUSB


I have downloaded the latest Manjaro KDE edition image (22.0.5) and flashed it to a USB stick using dd. I am trying to use it to install Manjaro on a desktop with an Intel 7600K and an Nvidia 1080Ti.

When I boot from disk, I selected to boot with proprietary drivers. The KDE desktop starts logging in, but then I only get the wallpaper image and nothing else. The mouse pointer does not appear. I cannot do anything. If I press the power button on my desktop, I get the KDE shutdown prompt.

If I try to boot with open source drivers, I get a complete black screen and I cannot do anything.

At this point, I’m not sure what else I could try. Any suggestions?

secure boot disabled in bios;
fast boot disabled in bios - you may not have this option;
fast startup disabled in windows, if you are dual booting;
AHCI enabled in bios, if you are on RAID, and you are dual booting, dont switch, otherwise you will not be able to boot into windows;
use Ventoy to flash the iso;

and boot with the ibt parameter:


Secure boot is disabled, fast boot was enabled but I disabled in the bios after your post. Fast startup is also disabled in Windows. AHCI is enabled. CSM is disabled. I did not use ventoy, so I reflashed the ISO with Ventoy this time…

I have attempted to use ibt=off without ventoy, but this didn’t do anything. With ventoy, ibt=off also didn’t do anything. This is both with proprietary and open source drivers. I am still facing the same issue

Worth mentioning… a few months ago I tried to boot Manjaro off a USB stick on the same machine (though the SSD installed was different). This was an older image, but I can’t remember what version exactly. It worked flawlessly.

so download from here the latest iso but with the linux515:

and try with it

1 Like

Well I figured it out. It is completely unrelated to anything.

My TV was connected to my desktop with HDMI, though it was only meant to be used as an alternate display to my monitor. The TV is usually switched off and I usually work on my Monitor, connected with displayport. This wasn’t a problem when I installed Windows… it identified my monitor as my main display. However, it seems Manjaro thought that my TV was my main display and it extended to my monitor as a secondary display (instead of mirroring). The TV was off, and all I could see was a wallpaper on my monitor while booting into the LiveUSB environment.

Disconnecting the TV and then booting again made it work perfectly fine. I was able to install Manjaro and it is working very well

Thank you very much for your help, and for introducing me to Ventoy!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.