Unable to get gamescope working

Hi,

I have an optimus laptop, with an Nvidia GTX1050Ti as the discrete gpu. I have the latest drivers installed (515.48.07). I am trying to get gamescope to work.

I have tried with the ‘gamescope’ and ‘gamescope-git’ packages, and also tried compiling it from source.
I have the necessary kernel modules loaded (nvidia nvidia_modeset nvidia_uvm nvidia_drm) in /etc/mkinitcpio.conf and "nvidia-drm.modeset=1 in /etc/default/grub.

No matter what I try, gamescope always returns the following error:

~ > gamescope -- vkcube
No CAP_SYS_NICE, falling back to regular-priority compute and threads.
Performance will be affected.
vulkan: selecting physical device 'NVIDIA GeForce GTX 1050': queue family 2
vulkan: physical device supports DRM format modifiers
vulkan: vkGetPhysicalDeviceFormatProperties2 returned zero modifiers for DRM format 0x3231564E (VkResult: 0)
vulkan: supported DRM formats for sampling usage:
vulkan:   0x34325241
vulkan:   0x34325258
wlserver: [backend/headless/backend.c:82] Creating headless backend
wlserver: Running compositor on wayland display 'gamescope-0'
wlserver: [backend/headless/backend.c:18] Starting headless backend
wlserver: [xwayland/server.c:92] Starting Xwayland on :1
No provider of eglGetCurrentContext found.  Requires one of:
    EGL 14
(EE) 
(EE) Backtrace:
(EE) 0: Xwayland (0x564c644ca000+0x1658c3) [0x564c6462f8c3]
(EE) 1: Xwayland (0x564c644ca000+0x1659c4) [0x564c6462f9c4]
(EE) 2: /usr/lib/libc.so.6 (0x7fa40ea4a000+0x3e8e0) [0x7fa40ea888e0]
(EE) 3: /usr/lib/libc.so.6 (0x7fa40ea4a000+0x8e36c) [0x7fa40ead836c]
(EE) 4: /usr/lib/libc.so.6 (raise+0x18) [0x7fa40ea88838]
(EE) 5: /usr/lib/libc.so.6 (abort+0xcf) [0x7fa40ea72535]
(EE) 6: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0xbfc8e) [0x7fa40ef23c8e]
(EE) 7: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0xbfcd0) [0x7fa40ef23cd0]
(EE) 8: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0xc105f) [0x7fa40ef2505f]
(EE) 9: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0xc3fdb) [0x7fa40ef27fdb]
(EE) 10: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0x5f277) [0x7fa40eec3277]
(EE) 11: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0x68387) [0x7fa40eecc387]
(EE) 12: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0x8b9ff) [0x7fa40eeef9ff]
(EE) 13: /usr/lib/libepoxy.so.0 (0x7fa40ee64000+0xc3b57) [0x7fa40ef27b57]
(EE) 14: Xwayland (0x564c644ca000+0x47439) [0x564c64511439]
(EE) 15: Xwayland (0x564c644ca000+0x44091) [0x564c6450e091]
(EE) 16: Xwayland (0x564c644ca000+0x3eac1) [0x564c64508ac1]
(EE) 17: Xwayland (0x564c644ca000+0x2f1ce) [0x564c644f91ce]
(EE) 18: /usr/lib/libc.so.6 (0x7fa40ea4a000+0x29290) [0x7fa40ea73290]
(EE) 19: /usr/lib/libc.so.6 (__libc_start_main+0x8a) [0x7fa40ea7334a]
(EE) 20: Xwayland (0x564c644ca000+0x31a75) [0x564c644fba75]
(EE) 
(EE) 
Fatal server error:
(EE) Caught signal 6 (Aborted). Server aborting
(EE) 
wlserver: [xwayland/server.c:247] Xwayland startup failed, not setting up xwm

I’m stumped. Can anyone help?

Welcome to the forum! :wave:

Are you using a Wayland session? Gamescope does not support Xorg (X11). If you’re not sure, check with:

echo $XDG_SESSION_TYPE

Welcome to the forum! :wave:

Thank you :slight_smile:

Are you using a Wayland session?

Yes, I am running Wayland. I use Wayfire as my compositor.

echo $XDG_SESSION_TYPE

returns ‘wayland’.

So what’s next?

Bump.

Is anyone capable of running gamescope on Manjaro?