Unable to find RAID boot device. Dropped into emergency shell

OK So I have a system that uses Intel RTSe with RAID 10. This contains Windows 10 and Manjaro, in witch the Manjaro installer was reporting the wrong disk size but I continued anyways and the installer and it “partly” worked.

Windows 10 made it out unscathed, but the Manjaro seems to be a different story.

After grub starts or the kernel manages to load, I’m drooped into a emergency shell.
Apparently, the RAID device cannot be found and using ls in the /dev directory dose not indicate that the RAID array is not seen, just the four hard drives.

The Live CD installer and Live environment is able to see, read, and write to the Linux and Windows RAID array, just Manjaro dose not boot.

Have you tried a search for a similar topic?

The thread on the link below might be related. Check this out:

Hope that helps!

Himm, I did through duck duck go and was stumped on if it was grub, kernel, or initramfs. But from what it seems to be, its initramfs needing a kernel module…

I try it out.

Well it kinda worked, It still can’t find UUID=XYZ but I got this new message.

Warning: /lib/modules/5.9.16-1-MANJARO/modules.devnam not found - ingoring
mount: /new_root: can't find UUID-f9c22b5c-d3ff-9187-84754(unreadable from image)

Then I’m back into the emergency shell

Did you add the module under chroot? If you didn’t, below there is a post on how to do the chroot:

Also, please note that kernel 5.9 is EOL. Please consider switching to latest stable (LTS 5.10).

You may want to provide further information as per the link below so that other users might be able to help out:

Well I looked at these two Arch Wiki’s (1) (2). And so far it did the same thing, and also, the keyboard is not responsive.

Now I did try chroot but not manjaro-chroot - auto so I’ll look into that.

And as far as the old kernel goes, I may have tried to use an older Manjaro ISO (thinking that the new image was buggy so I went with an older known working image). So once I get into the system, I’ll try to update.

Check this out:

So yes that I was able to fix the missing modules by using the manjaro-chroot command and that had so far fix pkinitfscfg problems not generating correctly.

Ok, glad you fixed your issues!

Please mark the thread as solved on the accepted solution and open up a new one if new issues come up. Thanks.

I will, i want to post the steps to fix the issue

So the issue was not with grub or the kernel, but instead the initramfs.

Manjaro uses a very empty initramfs conf file so the kernel modules (drivers) needed for the kernel to use the RAID array was missing from start up.

From the Arch Wiki on RAID and initramfs, you need set up the following in

HOOKS="base udev autodetect keyboard modconf block mdadm_udev dmraid filesystems fsck"

Once you have that set up, you do not want to use chroot but instead use manjaro-chroot to perform the rebuild.

And from a live Manjaro CD, create a temporary folder in the live environment (at the root level), and mount it (ie, mount /foldernamehere /dev/sdX or /dev/md126p3) then use manjaro-chroot /foldernamehere to change root then run mkinitcpio -p linux to generate a new module.

And so far I was able to boot the OS and make it to the desktop.