Unable to find any wifi connections

I have a Pinebook with Manjaro-ARM, KDE-Plasma desktop. I use it with a wireless router (PlusNet) . Yesterday I updated to 2020-08-25. All went well. However, today it seems unable to find any wifi connections. I am using a temporary wired connection at the moment. Of course, this may be a coincidence. My Raspbian Rpi4 connects by wifi, so the problem is not at the router end, though I have restarted the router just in case. Are there any commands with which I can test the wifi hardware in the Pinebook? Have patience, I am very much a beginner with Linux.

:+1: Welcome to Manjaro! :+1:

Please read this:

and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies…

An inxi --admin --verbosity=7 --filter --no-host would be the minimum required information… (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)


I did: inxi --admin --verbosity=7 --filter --no-boot > Public/mydata
then copied and pasted Public/mydata into this post, only to get a warning saying I couldn’t post links. What links? What do I do now? Sorry, this is rather new to me.

Does the network applet simply not show any wireless networks?
Have you tried toggling the Wifi checkbox in the applet on/off again?

That’s because you tried to link to a file on your local hard disk (which we cannot access) so just:

  • open that file,
  • copy the text,
  • respond to this message
  • type 3 backticks: ```
  • paste the file contents
  • type 3 more backtick.
  • hit Reply

and then your inxi output will look like this:

Like this

All of the above is described in the article I originally linked to, so please help us help you!


@Strit. No wireless networks shown, despite fact that I am using it on a different machine right now. There is no wifi checkbox. I presume by ‘applet’ you mean whatever is putting the network icon on the taskbar?

No wifi checkbox…?

It should be there. What image did you install from?

And what’s the output of:
pacman -Qi ap6256-firmware

And does sudo systemctl restart NetworkManager bring it back?
(the command is case sensitive)

1 Like

Sorry, forgot the backticks.

           parameters: initrd=/initramfs-linux.img console=tty1 console=ttyS0,115200 root=LABEL=ROOT_MNJRO rw 
           rootwait video=eDP-1:1920x1080@60 video=HDMI-A-1:1920x1080@60 
           Desktop: KDE Plasma 5.19.4 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM Distro: Manjaro ARM 
Machine:   Type: ARM Device System: Pinebook details: N/A serial: <filter> 
Battery:   ID-1: axp20x-battery charge: 86% condition: N/A volts: 3.9/2.9 model: N/A type: N/A serial: N/A 
           status: Discharging 
Memory:    RAM: total: 1.84 GiB used: 555.4 MiB (29.4%) 
           RAM Report: missing: Required program dmidecode not available 
CPU:       Topology: Quad Core model: N/A variant: cortex-a53 bits: 64 type: MCP arch: ARMv8 family: 8 
           model-id: N/A stepping: 4 microcode: N/A bogomips: 0 
           Speed: 1152 MHz min/max: 648/1152 MHz Core speeds (MHz): 1: 1152 2: 1152 3: 1152 4: 1152 
           Features: aes asimd cpuid crc32 evtstrm fp pmull sha1 sha2 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass status: Not affected 
           Type: spectre_v1 mitigation: __user pointer sanitization 
           Type: spectre_v2 status: Not affected 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: sun50i-a64-mali driver: lima v: kernel bus ID: N/A chip ID: allwinner:1c40000 
           Device-2: sun50i-a64-display-engine driver: sun4i_drm v: kernel bus ID: N/A 
           chip ID: allwinner:display-engine 
           Device-3: sun8i-a83t-dw-hdmi driver: N/A bus ID: N/A chip ID: allwinner:soc 
           Display: x11 server: X.org 1.20.8 driver: fbturbo compositor: kwin_x11 resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: simple-audio-card driver: N/A bus ID: N/A chip ID: simple-audio-card:soc 
           Device-2: simple-audio-card driver: asoc_simple_card bus ID: N/A chip ID: simple-audio-card:sound 
           Device-3: sun8i-a83t-dw-hdmi driver: N/A bus ID: N/A chip ID: allwinner:soc 
           Sound Server: ALSA v: k5.8.3-2-MANJARO-ARM 
Network:   Device-1: mmc-pwrseq-simple driver: pwrseq_simple v: N/A port: N/A bus ID: N/A 
           chip ID: mmc-pwrseq-simple:wifi_pwrseq 
           Device-2: sun50i-a64-emac driver: N/A port: N/A bus ID: N/A chip ID: allwinner:soc 
           WAN IP: No WAN IP data found. Connected to the web? SSL issues? 
Drives:    Local Storage: total: 58.24 GiB used: 10.70 GiB (18.4%) 
           ID-1: /dev/mmcblk2 model: DA4064 size: 58.24 GiB block size: physical: 512 B logical: 512 B 
           serial: <filter> rev: 0x8 scheme: MBR 
           Message: No Optical or Floppy data was found. 
RAID:      Message: No RAID data was found. 
Partition: ID-1: / raw size: 58.00 GiB size: 56.84 GiB (98.00%) used: 10.64 GiB (18.7%) fs: ext4 
           dev: /dev/mmcblk2p2 label: ROOT_MNJRO uuid: 7b8907d4-78a2-4c22-898b-b86260cc16b8 
           ID-2: /boot raw size: 213.6 MiB size: 213.4 MiB (99.89%) used: 60.5 MiB (28.4%) fs: vfat 
           dev: /dev/mmcblk2p1 label: BOOT_MNJRO uuid: 2D30-A679 
           ID-3: /var/lib/snapd/snap/core/9670 raw size: 85.8 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop0 label: N/A uuid: N/A 
           ID-4: /var/lib/snapd/snap/core/9806 raw size: 85.5 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop2 label: N/A uuid: N/A 
           ID-5: /var/lib/snapd/snap/micro/2600 raw size: 3.6 MiB size: <root required> used: <root required> 
           fs: squashfs dev: /dev/loop1 label: N/A uuid: N/A 
Unmounted: Message: No unmounted partitions found. 
USB:       Hub: 1-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 2-0:1 info: Full speed (or root) Hub ports: 1 rev: 2.0 speed: 480 Mb/s chip ID: 1d6b:0002 
           Hub: 2-1:2 info: Genesys Logic Hub ports: 4 rev: 2.0 speed: 480 Mb/s chip ID: 05e3:0608 
           Device-1: 2-1.1:3 info: USB2.0 Hub type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1 
           speed: 1.5 Mb/s chip ID: 258a:000c 
           Device-2: 2-1.2:4 info: MosArt Wireless Keyboard/Mouse type: Keyboard,Mouse driver: hid-generic,usbhid 
           interfaces: 2 rev: 1.1 speed: 12 Mb/s chip ID: 062a:4101 
           Device-3: 2-1.3:5 info: GEMBIRD Generic UVC 1.00 camera [AppoTech AX2311] type: Video driver: uvcvideo 
           interfaces: 2 rev: 2.0 speed: 480 Mb/s chip ID: 1908:2311 
           Hub: 3-0:1 info: Full speed (or root) Hub ports: 1 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001 
           Hub: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 1.1 speed: 12 Mb/s chip ID: 1d6b:0001 
Sensors:   System Temperatures: cpu: 40.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 167 Uptime: 17m Init: systemd v: 246 Compilers: gcc: 10.2.0 Shell: bash v: 5.0.18 
           running in: konsole inxi: 3.0.37 

Ah, this is the original Pinebook.

What kernel are you on?

5.8.3-2-MANJARO-ARM aarch64

Hm. did you get any errors when updating? Like DKMS errors?

Try reinstalling the wifi driver with:
sudo pacman -S dkms-rtl8723cs

If that produces something that might look like errors, please post them.

1 Like

The image was reinstalled on June 24 by the company, RComp, that I bought it from.
Currently the kernel is 5.8.3-2-MANJARO-ARM. It was working well until a few days ago.

Output from ‘pacman -Qi ap6256 -firmware’:
error: invalid option ‘-f’

Output from ‘sudo systemctl restart NetworkManager’:
Failed to restart NetworkManager.service: Unit Network.Manager .service not found.

That’s a huge issue. That service file should be there on all our Pinebook images.

If I was you, I would try:
sudo pacman -S dkms-rtl8723cs networkmanager

If any errors, please post them.

If successful, reboot and see if you have wifi.

:: Processing package changes…
(1/1) reinstalling dkms-rtl8723cs
Error! Could not find module source directory.
Directory: /usr/src/rtl8723cs-2020.03.15 does not exist.
error: command failed to execute correctly


Try this command instead:
sudo pacman-mirrors -f5 && sudo pacman -Syyu dkms-rtl8723cs networkmanager

Rebooted after reload of networkmanager but no change. No wireless access points shown. In configuring the Wi-Fi connection should the mode be

Access Point, Infrastructure or Ad-hoc?

Though I suspect that this is a superficial detail by comparison.

Strit, Jeg sku’ alligevel tilsaet mange tak for Deres tryllekunstlige svarer. Jeg gaetter at problemet stemmer fra hardware mere end software.

Does this mean we have to close this topic as “Hardware error”?

If not: You are connected through Ethernet while trying to solve the WiFi issue, right?

(Sorry! Just checking! Don’t kill the messenger! :scream: )

Yes. I have Raspbian on an Rpi4 that talks to my router by wifi, and a Pinebook with Manjaro-ARM that used to do that, but now can be connected by ethernet2usb cable. I use Chrome on the former, Firefox on the latter.

Topic administratively closed as:

Hardware error…