Unable to create bootable USB stick from latest ISO file

I’m trying to create a bootable USB drive with the latest manjaro kde iso image at the official site, version 221224 (checked checksum etc).

First, tried to create with Suse studio imagewriter under manjaro gnome but my Lenovo T480 would not recognize the stick.

Second, tried to create with rufus under windows 8 but again my Lenovo T480 would not recognize the stick.
Here I should note that Rufus did display a big notice it could only create it in DD mode…ISO hybrid…

Third, tried latest endevour os iso file with rufus under windows 8. Rufus did it in iso mode. This made the USB stick bootable.

Any advice with the manjaro iso file?

whether windows or linux is not important for this one:
get and install Ventoy
It is available for both platforms.
initialize your USB drive using it
then simply copy the ISO to that drive

I have no experience whatsoever with tools running on windows - like rufus.

Ventoy creates a bootable USB drive which can still be used as regular storage afterwards.
You simply copy any number of ISO’s to it - and it will present them to you as options to boot
when you boot from the Ventoy USB.


does it recognize any stick?
It may be an option in the bios/UEFI
from which device it should be trying to boot first
… or hit some F key, like F2 or F8 as soon as you see the first activity - or even in the short interval before that
to access this option without changing a setting in the Bios

which key it is is dependent on the particular bios of your machine

1 Like

As I mentioned before, using the latest endevourOS iso file with rufus under windows 8 made the USB stick bootable, so my Lenovo T480 started the EOS Live installer.
But following your advice, I went ahead and installed Ventoy on Manjaro Gnome. That way my T480 recognized the USB stick even I used the exact same manjaro ISO file (that failed before with rufus and suse imagewriter).

Thanks for your great help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.