Unable to control fan on Gigabyte B560M DS3H V2 (chip IT8689)

Hi everyone.

I got my hardware upgraded to:
Gigabyte B560M DS3H V2 + Intel i5-10400

One of the annoying problems I’m experiencing is lack of fan control.

pwmconfig doesn’t detect my chip (according to info from Windows cpu-z it’s ITE IT8689), meanwhile I have only temp sensors (detected by lm-sensors) available in /sys/class/hwmon/

For my old motherboard I had ability to control pwm

  1. I’ve upgraded to latest BIOS
  2. Tried to add it87 chip with modprobe (device isn’t found) after I read on kernel mailing list that they won’t add support for IT8669 (first result in google search) IOSuper chip.

Everything I want to set fans turn on when hitting 60 degrees and stop when drop down to 40 with fancontrol, but BIOS doesn’t stop fans with Smart Fan 6 when temp drops down to 40 and keeping cooling CPU even when temp is 20.

I know, it’s not something Manjaro related, but maybe you have some suggestions.

Also, Manjaro (even installation media) isn’t booting on 5.10 and earlier kernels with Hardware error, while with 5.15 it’s Okay (even I see error is still there).

Problem with ITE IT8689 chip was solved:

  1. Installed package it87-dkms-git from AUR

  2. In file /etc/default/grub/grub.cfg added
    to existing parameters GRUB_CMDLINE_LINUX_DEFAULT=""

  3. Run grub-mkconfig -o /boot/grub/grub.cfg to refresh config

  4. Added kernel module with modprobe it87 force_id=0x8628

  5. Tested with sensors. Also pwmconfig found new hwmon in /sys/class/hwmon

  6. After testing added options it87 force_id=0x8628 to /etc/modprobe.d/it87.conf

  7. it87 to file /etc/modules

  8. Rebooted

Tested in 5.15 and 5.16

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.