Unable to connect to self-hosted vpn

Well this is a strange one. I am away from home, connected to wifi and am unable to connect to my self-hosted vpn running on my home network. I cannot ping the address, nor the IP. Internet works just fine, I am able to browse the web and I am posting this forum message right now. The really strange part is that my phone is connected to the same wifi network and I am able to connect to the VPN just fine. I even tried connecting to my phone via tethering and I am still unable to ping or connect.

What’s going on here? Thanks.

I am able to ping www.google.com and

Home networks have usually IP’s that are not accessible by the internet (routable), like 192.168.x.x or 10.x.x.x
That’s why…

If you have a different setup then please provide acurate IP info of all machines involved inclusive your Router and self hosted VPN IP.

Well, like I said, I am able to connect on my phone and the appropriate ports are forwarded so that’s not the issue.

I have a sub domain that points to my home networks public IP, but I cannot ping that address or the actual public IP from my Manjaro laptop despite being able to connect just fine on my phone connected to the same wifi network (this is not my wifi network that my laptop and phone are connected to, perhaps that wasnt clear and why you’re asking me about internal IP addresses)

Ping is a protocol that is not forwarded and blocked by default on many ISP provided routers…
Also please use newlines when a sentence ends :wink:

Without actual IP info there is not much anyone can assist further, because we can’t check…
(There is also IPv4 vs IPv6 etc involved)

Ping shouldn’t be forwarded in this case, but I should be able to ping the VPN server itself. I’m not talking about resources on the on network, but the public address of the VPN itself. That should be reachable (and is on another device).

I don’t believe you need my IP address as I’ve already established that the server is up and reachable, the problem lies with the Manjaro client.

IPV4 only. My ISP does not support IPV6

EDIT: I misunderstood your first sentence. I am able to ping Google just fine and can connect to my VPN server on my phone via the same wifi (and therefore ISP) so I don’t believe that’s the issue. The issue must lie with the Manjaro client.

Which app are you talking about, or do you mean the system running Manjaro itself? :thinking:

The client machine, running Manjaro

Did you try to connect to your VPN using that phone but use Mobile internet instead of WiFi? :thinking:
If that fails, it means your VPN’s IP is NOT reachable from the Internet afterall, and thus not the problem of the Manjaro install…

I am able to connect to my vpn server on my phone both via this wifi and via cell connection.

Can we move past trying to convince me that the issue is not the machine running Manjaro? I’ve established that from the first post. Thanks.

That’s not my intention at all, im trying to do problem elimination that’s all…

hmmm interesting new development, I am able to connect to my ftp server via the manjaro laptop. The ftp server is on the same IP as the vpn server.

So lets recap:

  1. You have a self hosted VPN on one of your machines. (Not running Manjaro)
  2. You seem to have proper internet connection on your machines, because you can ping google by DNS and IP.
  3. You can ping and connect to your VPN using your Wifi via Phone.
  4. You can connect to your FTP server, that runs on the VPN machine, with all machines.

But you are unable to connect/ping to your VPN server when not using your WiFi? :thinking:

  1. Are you using the Public IP in cases (3) and (4), or the internal LAN IP?
  2. Does dig or similar command properly return the Public IP of your VPN server?

Almost, manjaro machine and phone are currently on my parents wifi, not my wifi. Phone connects, laptop does not, but they are both not on my home wifi. FTP server is on a different machine (actual sever on my home network, where as the vpn is running on the router itself.)

3 & 4 are both using public IP.

dig does return correct public IP for the vpn server.

Ok then, excuse me for asking, but how do you connect to your VPN?
Via a route setting or like a Windows Share?
Eg. define “connect” in this context.

What do you mean? I use openvpn via network manager

Aha…okay…now we got some actual info :smile:
Let me think more about this problem, and hopefully others can assist more in mean time…

I added openvpn as tag to your OP, so it will be exposed more as such…

Just double checked all my certs, keys, and ciphers… they are correct.

Hope others can chime-in in mean time because it’s 03:25 where i am :wink:

I think the issue is that my router is using an ancient version of openvpn server and will only allow the use of AES-128-CBC data cipher, which newer versions of openvpn will no longer connect to. I am currently trying to figure out how to configure data-ciper-fallback (I see this is the error log) but I cannot seem to figure out how to do this when using openvpn via NetworkManager. I’ve tried putting it into the config file in /etc/NetworkManager/system-connections but no dice.

I may just have to set up a new server that doesn’t rely on the outdated package on my router…

If someone can help me force openvpn to connect I could actually do that…